Pārlūkot izejas kodu

python: use Build/Prepare rule for the config.site file

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Alexandru Ardelean 10 gadus atpakaļ
vecāks
revīzija
94b090cb9c
1 mainītis faili ar 2 papildinājumiem un 4 dzēšanām
  1. 2
    4
      lang/python/Makefile

+ 2
- 4
lang/python/Makefile Parādīt failu

@@ -97,13 +97,11 @@ CONFIGURE_ARGS+= \
97 97
 	CONFIG_SITE="$(PKG_BUILD_DIR)/config.site" \
98 98
 	OPT="$(TARGET_CFLAGS)"
99 99
 
100
-define Hooks/Configure/Pre/ConfigSiteInstall
100
+define Build/Prepare
101
+	$(call Build/Prepare/Default)
101 102
 	$(CP) ./files/config.site $(PKG_BUILD_DIR)/config.site
102 103
 endef
103 104
 
104
-Hooks/Configure/Pre+=\
105
-	Hooks/Configure/Pre/ConfigSiteInstall
106
-
107 105
 define Build/InstallDev
108 106
 	$(INSTALL_DIR) $(STAGING_DIR)/mk/
109 107
 	$(INSTALL_DIR) $(1)/usr/include/ $(1)/usr/lib/