瀏覽代碼

Merge pull request #1294 from mar-kolya/add-bridge-utils

Move bridge-utils from oldpackages
Ted Hess 9 年之前
父節點
當前提交
9589efa5bc

+ 52
- 0
net/bridge-utils/Makefile 查看文件

@@ -0,0 +1,52 @@
1
+#
2
+# Copyright (C) 2006-2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+include $(INCLUDE_DIR)/kernel.mk
10
+
11
+PKG_NAME:=bridge-utils
12
+PKG_VERSION:=1.5
13
+PKG_RELEASE:=3
14
+
15
+PKG_SOURCE_PROTO:=git
16
+PKG_SOURCE_URL:=https://git.kernel.org/pub/scm/linux/kernel/git/shemminger/bridge-utils.git
17
+PKG_SOURCE_VERSION:=v${PKG_VERSION}
18
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
19
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
20
+
21
+PKG_LICENSE:=GPL-2.0+
22
+PKG_LICENSE_FILES:=COPYING
23
+PKG_FIXUP:=autoreconf
24
+
25
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
26
+
27
+include $(INCLUDE_DIR)/package.mk
28
+
29
+define Package/bridge
30
+  SECTION:=net
31
+  CATEGORY:=Base system
32
+  TITLE:=Ethernet bridging configuration utility
33
+  URL:=http://bridge.sourceforge.net/
34
+  PKG_MAINTAINER:=Nikolay Martynov <mar.kolya@gmail.com>
35
+endef
36
+
37
+define Package/bridge/description
38
+ Manage ethernet bridging: a way to connect networks together to
39
+ form a larger network.
40
+endef
41
+
42
+TARGET_CFLAGS += -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE
43
+
44
+CONFIGURE_ARGS += \
45
+	--with-linux-headers="$(LINUX_DIR)" \
46
+
47
+define Package/bridge/install
48
+	$(INSTALL_DIR) $(1)/usr/sbin
49
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/brctl/brctl $(1)/usr/sbin
50
+endef
51
+
52
+$(eval $(call BuildPackage,bridge))

+ 11
- 0
net/bridge-utils/patches/001-libbridge_cflags.patch 查看文件

@@ -0,0 +1,11 @@
1
+--- a/libbridge/Makefile.in
2
++++ b/libbridge/Makefile.in
3
+@@ -5,7 +5,7 @@ AR=ar
4
+ RANLIB=@RANLIB@
5
+ 
6
+ CC=@CC@
7
+-CFLAGS = -Wall -g $(KERNEL_HEADERS)
8
++CFLAGS = -Wall -g @CFLAGS@ $(KERNEL_HEADERS)
9
+ 
10
+ prefix=@prefix@
11
+ exec_prefix=@exec_prefix@

+ 10
- 0
net/bridge-utils/patches/010-fix_struct_in6_addr_usage.patch 查看文件

@@ -0,0 +1,10 @@
1
+--- a/libbridge/libbridge.h
2
++++ b/libbridge/libbridge.h
3
+@@ -20,6 +20,7 @@
4
+ #define _LIBBRIDGE_H
5
+ 
6
+ #include <sys/socket.h>
7
++#include <netinet/in.h>
8
+ #include <linux/if.h>
9
+ #include <linux/if_bridge.h>
10
+