Pārlūkot izejas kodu

Merge pull request #1410 from jow-/libnet-musl-compat

libnet-1.2.x: fix musl compatiblity
Luka Perkov 9 gadus atpakaļ
vecāks
revīzija
95f5cf9c04

+ 1
- 1
libs/libnet-1.2.x/Makefile Parādīt failu

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=libnet
11 11
 PKG_VERSION:=1.2-rc3
12
-PKG_RELEASE:=1
12
+PKG_RELEASE:=2
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=http://sourceforge.net/projects/libnet-dev/files/

+ 11
- 0
libs/libnet-1.2.x/patches/100-musl-compat.patch Parādīt failu

@@ -0,0 +1,11 @@
1
+--- a/src/libnet_link_linux.c
2
++++ b/src/libnet_link_linux.c
3
+@@ -30,7 +30,7 @@
4
+ #include <sys/time.h>
5
+ 
6
+ #include <net/if.h>
7
+-#if (__GLIBC__)
8
++#if (!__UCLIBC__)
9
+ #include <netinet/if_ether.h>
10
+ #include <net/if_arp.h>
11
+ #else