|
@@ -0,0 +1,52 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2008-2014 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=wavemon
|
|
11
|
+PKG_VERSION:=0.7.6
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
|
15
|
+PKG_SOURCE_URL:=http://eden-feed.erg.abdn.ac.uk/wavemon/stable-releases
|
|
16
|
+PKG_MD5SUM:=c60e25feb8b1785cf14371556f0613f4
|
|
17
|
+
|
|
18
|
+PKG_INSTALL:=1
|
|
19
|
+
|
|
20
|
+include $(INCLUDE_DIR)/package.mk
|
|
21
|
+
|
|
22
|
+define Package/wavemon
|
|
23
|
+ SECTION:=net
|
|
24
|
+ CATEGORY:=Network
|
|
25
|
+ MAINTAINER:=Jonathan McCrohan <jmccrohan@gmail.com>
|
|
26
|
+ TITLE:=N-curses based wireless network devices monitor
|
|
27
|
+ DEPENDS:=+libncurses +libpthread
|
|
28
|
+ SUBMENU:=wireless
|
|
29
|
+ URL:=http://eden-feed.erg.abdn.ac.uk/wavemon/
|
|
30
|
+endef
|
|
31
|
+
|
|
32
|
+define Package/wavemon/description
|
|
33
|
+ wavemon is a ncurses-based monitoring application for wireless network
|
|
34
|
+ devices. It currently works under Linux with devices that are supported
|
|
35
|
+ by the wireless extensions by Jean Tourrilhes (included in Kernel 2.4
|
|
36
|
+ and higher), e.g. the Lucent Orinoco cards.
|
|
37
|
+endef
|
|
38
|
+
|
|
39
|
+CONFIGURE_VARS += \
|
|
40
|
+ ac_cv_lib_cap_cap_get_flag=no
|
|
41
|
+
|
|
42
|
+TARGET_CFLAGS += -pthread
|
|
43
|
+
|
|
44
|
+MAKE_FLAGS += \
|
|
45
|
+ CFLAGS="$(TARGET_CFLAGS) -L$(STAGING_DIR)/usr/lib -I$(STAGING_DIR)/usr/include"
|
|
46
|
+
|
|
47
|
+define Package/wavemon/install
|
|
48
|
+ $(INSTALL_DIR) $(1)/usr/bin
|
|
49
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/wavemon $(1)/usr/bin/
|
|
50
|
+endef
|
|
51
|
+
|
|
52
|
+$(eval $(call BuildPackage,wavemon))
|