|
@@ -9,8 +9,9 @@ include $(TOPDIR)/rules.mk
|
9
|
9
|
|
10
|
10
|
PKG_NAME:=libshout
|
11
|
11
|
PKG_VERSION:=2.3.1
|
12
|
|
-PKG_RELEASE:=1
|
|
12
|
+PKG_RELEASE:=2
|
13
|
13
|
|
|
14
|
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
|
14
|
15
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
15
|
16
|
PKG_SOURCE_URL:=http://downloads.us.xiph.org/releases/libshout/
|
16
|
17
|
PKG_MD5SUM:=11765b2592e7ea623ccd93d3f8df172c
|
|
@@ -24,12 +25,25 @@ PKG_INSTALL:=1
|
24
|
25
|
|
25
|
26
|
include $(INCLUDE_DIR)/package.mk
|
26
|
27
|
|
27
|
|
-define Package/libshout
|
|
28
|
+define Package/libshout/default
|
28
|
29
|
SECTION:=libs
|
29
|
30
|
CATEGORY:=Libraries
|
30
|
|
- TITLE:=Library which can be used to write a source client like ices
|
|
31
|
+ TITLE:=Shoutcast client library
|
31
|
32
|
URL:=http://www.icecast.org/download.php
|
32
|
|
- DEPENDS:= +libspeex +libtheora +libvorbis +libvorbisidec +libpthread
|
|
33
|
+ DEPENDS:= +libvorbis +libvorbisidec +libpthread
|
|
34
|
+endef
|
|
35
|
+
|
|
36
|
+define Package/libshout
|
|
37
|
+ $(call Package/libshout/default)
|
|
38
|
+ TITLE+= (no speex & theora)
|
|
39
|
+ VARIANT:=nospeex
|
|
40
|
+endef
|
|
41
|
+
|
|
42
|
+define Package/libshout-full
|
|
43
|
+ $(call Package/libshout/default)
|
|
44
|
+ TITLE+= (all codecs)
|
|
45
|
+ DEPENDS+= +libspeex +libtheora
|
|
46
|
+ VARIANT:=full
|
33
|
47
|
endef
|
34
|
48
|
|
35
|
49
|
define Package/libshout/description
|
|
@@ -40,9 +54,15 @@ define Package/libshout/description
|
40
|
54
|
details.
|
41
|
55
|
endef
|
42
|
56
|
|
|
57
|
+Package/libshout-full/description=Package/libshout/description
|
|
58
|
+
|
43
|
59
|
CONFIGURE_ARGS += \
|
44
|
60
|
--enable-shared \
|
45
|
|
- --enable-static \
|
|
61
|
+ --enable-static
|
|
62
|
+
|
|
63
|
+ifeq ($(BUILD_VARIANT),full)
|
|
64
|
+ CONFIGURE_ARGS += --with-theora=no --with-speex=no
|
|
65
|
+endif
|
46
|
66
|
|
47
|
67
|
CONFIGURE_VARS += \
|
48
|
68
|
VORBIS_CFLAGS="-I$(STAGING_DIR)/usr/include/tremor/" \
|
|
@@ -64,5 +84,7 @@ define Package/libshout/install
|
64
|
84
|
$(INSTALL_DIR) $(1)/usr/lib
|
65
|
85
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libshout.so.* $(1)/usr/lib/
|
66
|
86
|
endef
|
|
87
|
+Package/libshout-full/install=Package/libshout/install
|
67
|
88
|
|
68
|
89
|
$(eval $(call BuildPackage,libshout))
|
|
90
|
+$(eval $(call BuildPackage,libshout-full))
|