Browse Source

mwan3: update to version 1.5-8

Fix bug introduced in version 1.5-7; args were not parsed to script.

Signed-off-by: Jeroen Louwes <jeroen.louwes@gmail.com>
Adze1502 10 years ago
parent
commit
964a4ebe1f
2 changed files with 11 additions and 3 deletions
  1. 1
    1
      net/mwan3/Makefile
  2. 10
    2
      net/mwan3/files/usr/sbin/mwan3

+ 1
- 1
net/mwan3/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=mwan3
11 11
 PKG_VERSION:=1.5
12
-PKG_RELEASE:=7
12
+PKG_RELEASE:=8
13 13
 PKG_MAINTAINER:=Jeroen Louwes <jeroen.louwes@gmail.com>
14 14
 PKG_LICENSE:=GPLv2
15 15
 

+ 10
- 2
net/mwan3/files/usr/sbin/mwan3 View File

@@ -202,5 +202,13 @@ restart() {
202 202
 	start
203 203
 }
204 204
 
205
-action=${1:-help}
206
-$action
205
+case "$1" in
206
+	ifup|ifdown|interfaces|policies|rules|status|start|stop|restart)
207
+		$*
208
+	;;
209
+	*)
210
+		help
211
+	;;
212
+esac
213
+
214
+exit 0