浏览代码

Revert "xl2tpd: rename netifd protocol handler to l2tpv2 to avoid clashes with l2tpv3"

This reverts commit 981f2da457.
OpenWrt wiki knew l2tp from l2tpv3tun, but luci knew l2tp from xl2tpd
Steven Barth 10 年前
父节点
当前提交
96b04afce6
共有 2 个文件被更改,包括 5 次插入5 次删除
  1. 1
    1
      net/xl2tpd/Makefile
  2. 4
    4
      net/xl2tpd/files/l2tp.sh

+ 1
- 1
net/xl2tpd/Makefile 查看文件

@@ -67,7 +67,7 @@ define Package/xl2tpd/install
67 67
 	$(INSTALL_DATA) ./files/options.xl2tpd $(1)/etc/ppp/
68 68
 
69 69
 	$(INSTALL_DIR) $(1)/lib/netifd/proto
70
-	$(INSTALL_BIN) ./files/l2tpv2.sh $(1)/lib/netifd/proto
70
+	$(INSTALL_BIN) ./files/l2tp.sh $(1)/lib/netifd/proto
71 71
 endef
72 72
 
73 73
 $(eval $(call BuildPackage,xl2tpd))

net/xl2tpd/files/l2tpv2.sh → net/xl2tpd/files/l2tp.sh 查看文件

@@ -8,7 +8,7 @@
8 8
 	init_proto "$@"
9 9
 }
10 10
 
11
-proto_l2tpv2_init_config() {
11
+proto_l2tp_init_config() {
12 12
 	proto_config_add_string "username"
13 13
 	proto_config_add_string "password"
14 14
 	proto_config_add_string "keepalive"
@@ -20,7 +20,7 @@ proto_l2tpv2_init_config() {
20 20
 	no_device=1
21 21
 }
22 22
 
23
-proto_l2tpv2_setup() {
23
+proto_l2tp_setup() {
24 24
 	local config="$1"
25 25
 	local iface="$2"
26 26
 	local optfile="/tmp/l2tp/options.${config}"
@@ -77,7 +77,7 @@ proto_l2tpv2_setup() {
77 77
 	xl2tpd-control connect l2tp-${config}
78 78
 }
79 79
 
80
-proto_l2tpv2_teardown() {
80
+proto_l2tp_teardown() {
81 81
 	local interface="$1"
82 82
 	local optfile="/tmp/l2tp/options.${interface}"
83 83
 
@@ -103,5 +103,5 @@ proto_l2tpv2_teardown() {
103 103
 }
104 104
 
105 105
 [ -n "$INCLUDE_ONLY" ] || {
106
-	add_protocol l2tpv2
106
+	add_protocol l2tp
107 107
 }