|
@@ -0,0 +1,62 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2011 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=libprotobuf-c
|
|
11
|
+PKG_VERSION:=2014-06-30
|
|
12
|
+PKG_RELEASE:=$(PKG_SOURCE_VERSION)
|
|
13
|
+
|
|
14
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
|
15
|
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
|
16
|
+PKG_SOURCE_URL:=git://github.com/protobuf-c/protobuf-c.git
|
|
17
|
+PKG_SOURCE_PROTO:=git
|
|
18
|
+PKG_SOURCE_VERSION:=6136f54b221ab8883731349d01f34b01812e391d
|
|
19
|
+
|
|
20
|
+PKG_INSTALL:=1
|
|
21
|
+
|
|
22
|
+include $(INCLUDE_DIR)/package.mk
|
|
23
|
+
|
|
24
|
+define Package/libprotobuf-c
|
|
25
|
+ TITLE:=Protocol Buffers library
|
|
26
|
+ SECTION:=libs
|
|
27
|
+ CATEGORY:=Libraries
|
|
28
|
+ URL:=http://code.google.com/p/protobuf-c/
|
|
29
|
+endef
|
|
30
|
+
|
|
31
|
+define Package/libprotobuf-c/description
|
|
32
|
+ Runtime library to use Google Protocol Buffers from C applications.
|
|
33
|
+ Protocol Buffers are a way of encoding structured data in an efficient yet
|
|
34
|
+ extensible format. Google uses Protocol Buffers for almost all of its
|
|
35
|
+ internal RPC protocols and file formats.
|
|
36
|
+endef
|
|
37
|
+
|
|
38
|
+CONFIGURE_ARGS += \
|
|
39
|
+ --enable-shared \
|
|
40
|
+ --enable-static \
|
|
41
|
+ --disable-protoc
|
|
42
|
+
|
|
43
|
+define Build/Configure
|
|
44
|
+ cd $(PKG_BUILD_DIR) && ./autogen.sh
|
|
45
|
+ $(call Build/Configure/Default)
|
|
46
|
+endef
|
|
47
|
+
|
|
48
|
+define Build/InstallDev
|
|
49
|
+ $(INSTALL_DIR) $(1)/usr/include/
|
|
50
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
|
|
51
|
+ $(INSTALL_DIR) $(1)/usr/lib
|
|
52
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libprotobuf-c.{a,la,so*} $(1)/usr/lib/
|
|
53
|
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
|
|
54
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* $(1)/usr/lib/pkgconfig/
|
|
55
|
+endef
|
|
56
|
+
|
|
57
|
+define Package/libprotobuf-c/install
|
|
58
|
+ $(INSTALL_DIR) $(1)/usr/lib
|
|
59
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libprotobuf-c.so.* $(1)/usr/lib/
|
|
60
|
+endef
|
|
61
|
+
|
|
62
|
+$(eval $(call BuildPackage,libprotobuf-c))
|