Browse Source

global: change all instances of USE_EGLIBC to USE_GLIBC

Signed-off-by: John Crispin <blogic@openwrt.org>
John Crispin 10 years ago
parent
commit
98be2ca3e0

+ 1
- 1
devel/diffutils/Makefile View File

@@ -24,7 +24,7 @@ include $(INCLUDE_DIR)/package.mk
24 24
 define Package/diffutils
25 25
   SECTION:=devel
26 26
   CATEGORY:=Development
27
-  DEPENDS:=+USE_EGLIBC:librt
27
+  DEPENDS:=+USE_GLIBC:librt
28 28
   TITLE:=diffutils
29 29
   URL:=http://www.gnu.org/software/diffutils/
30 30
 endef

+ 1
- 1
lang/luaposix/Makefile View File

@@ -42,7 +42,7 @@ CONFIGURE_VARS += ac_cv_path_LDOC=""
42 42
 
43 43
 TARGET_CFLAGS += -DLUA_USE_LINUX $(FPIC) -std=gnu99
44 44
 
45
-ifneq ($(CONFIG_USE_EGLIBC),)
45
+ifneq ($(CONFIG_USE_GLIBC),)
46 46
   ifeq ($(CONFIG_EGLIBC_OPTION_EGLIBC_UTMP),)
47 47
     TARGET_CFLAGS += -DNO_GETLOGIN
48 48
   endif

+ 1
- 1
lang/perl/Config.in View File

@@ -3,7 +3,7 @@ menu "Configuration"
3 3
 
4 4
 config PERL_THREADS
5 5
     bool "Enable threading support"
6
-    default y if (mips || mipsel || i386 || i686 || x86_64 || armeb || arm) && (USE_UCLIBC || USE_EGLIBC)
6
+    default y if (mips || mipsel || i386 || i686 || x86_64 || armeb || arm) && (USE_UCLIBC || USE_GLIBC)
7 7
     default n
8 8
 
9 9
 config PERL_TESTS

+ 3
- 3
lang/perl/Makefile View File

@@ -36,7 +36,7 @@ HOST_BUILD_PARALLEL:=1
36 36
 
37 37
 # Variables used during configuration/build
38 38
 HOST_PERL_PREFIX:=$(STAGING_DIR_HOST)/usr
39
-ifneq ($(CONFIG_USE_EGLIBC),)
39
+ifneq ($(CONFIG_USE_GLIBC),)
40 40
 	EXTRA_LIBS:=bsd
41 41
 	EXTRA_LIBDIRS:=$(STAGING_DIR)/lib
42 42
 endif
@@ -50,7 +50,7 @@ ifdef CONFIG_PERL_THREADS
50 50
 	PERL_CONFIG_SUFFIX:=-mt
51 51
 
52 52
 	# uclibc doesn't provide crypt_r(). Enable crypt() usage for glibc builds only
53
-	ifdef CONFIG_USE_EGLIBC
53
+	ifdef CONFIG_USE_GLIBC
54 54
 		CRYPT_R_PROTO:=REENTRANT_PROTO_B_CCS
55 55
 		CRYPT:=define
56 56
 	else
@@ -79,7 +79,7 @@ define Package/perl
79 79
   CATEGORY:=Languages
80 80
   TITLE:=The Perl intepreter
81 81
   URL:=http://www.perl.com/
82
-  DEPENDS:=+USE_EGLIBC:libbsd +PERL_THREADS:libpthread
82
+  DEPENDS:=+USE_GLIBC:libbsd +PERL_THREADS:libpthread
83 83
 endef
84 84
 
85 85
 define Package/perl/description

+ 1
- 1
lang/perl/perlmod.mk View File

@@ -3,7 +3,7 @@
3 3
 
4 4
 # Build environment
5 5
 HOST_PERL_PREFIX:=$(STAGING_DIR_HOST)/usr
6
-ifneq ($(CONFIG_USE_EGLIBC),)
6
+ifneq ($(CONFIG_USE_GLIBC),)
7 7
 	EXTRA_LIBS:=bsd
8 8
 	EXTRA_LIBDIRS:=$(STAGING_DIR)/lib
9 9
 endif

+ 1
- 1
utils/pciutils/Makefile View File

@@ -50,7 +50,7 @@ MAKE_FLAGS += \
50 50
 	HOST="$(GNU_TARGET_NAME)" \
51 51
 	ZLIB="yes" \
52 52
 
53
-ifneq ($(CONFIG_USE_EGLIBC),)
53
+ifneq ($(CONFIG_USE_GLIBC),)
54 54
 TARGET_LDFLAGS += -lresolv
55 55
 endif
56 56