Procházet zdrojové kódy

giflib: Import from oldpackages, update to latest version, add myself as maintainer

Signed-off-by: Ted Hess <thess@kitschensync.net>
Ted Hess před 9 roky
rodič
revize
99263ff573
1 změnil soubory, kde provedl 61 přidání a 0 odebrání
  1. 61
    0
      libs/giflib/Makefile

+ 61
- 0
libs/giflib/Makefile Zobrazit soubor

@@ -0,0 +1,61 @@
1
+#
2
+# Copyright (C) 2006-2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=giflib
11
+PKG_VERSION:=5.1.1
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
15
+PKG_SOURCE_URL:=@SF/giflib
16
+PKG_MD5SUM:=1c39333192712788c6568c78a949f13e
17
+
18
+PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
19
+
20
+PKG_LICENSE:=MIT
21
+PKG_LICENSE_FILES:=COPYING
22
+
23
+PKG_FIXUP:=autoreconf
24
+PKG_REMOVE_FILES:=autogen.sh aclocal.m4
25
+
26
+include $(INCLUDE_DIR)/package.mk
27
+
28
+define Package/giflib
29
+  SECTION:=libs
30
+  CATEGORY:=Libraries
31
+  TITLE:=GIF libraries
32
+  URL:=http://sourceforge.net/projects/giflib
33
+endef
34
+
35
+define Package/giflib/description
36
+  giflib is a library for reading and writing gif images.
37
+  It is API and ABI compatible with libungif which was in wide use while
38
+  the LZW compression algorithm was patented.
39
+endef
40
+
41
+TARGET_CFLAGS += $(FPIC)
42
+CONFIGURE_ARGS += --enable-x11=no
43
+
44
+define Build/Compile
45
+	$(MAKE) -C $(PKG_BUILD_DIR)
46
+endef
47
+
48
+define Build/InstallDev
49
+	$(INSTALL_DIR) $(1)/usr/{lib,include}
50
+	$(CP) $(PKG_BUILD_DIR)/lib/.libs/lib*so* $(1)/usr/lib
51
+	$(CP) $(PKG_BUILD_DIR)/lib/.libs/libgif.a $(1)/usr/lib
52
+	$(CP) $(PKG_BUILD_DIR)/lib/libgif.la $(1)/usr/lib
53
+	$(CP) $(PKG_BUILD_DIR)/lib/*.h $(1)/usr/include/
54
+endef
55
+
56
+define Package/giflib/install
57
+	$(INSTALL_DIR) $(1)/usr/lib
58
+	$(CP) $(PKG_BUILD_DIR)/lib/.libs/lib*so* $(1)/usr/lib/
59
+endef
60
+
61
+$(eval $(call BuildPackage,giflib))