Browse Source

python: fix two build depend issues

Build depends must refer to the source package name, not the binary one,
therefore we need to use `bzip2` in order to enforce a build of libbz2.so.

Also make the host python build depend on the bzip2 host build in order to
ensure that host python is built with bzip2 support. We don't need a build
dependency for the target python as this already depends on +libbz2 through
python-light. That package dependency in turn implies a build dependency.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Jo-Philipp Wich 9 years ago
parent
commit
99484ec990
1 changed files with 2 additions and 1 deletions
  1. 2
    1
      lang/python/Makefile

+ 2
- 1
lang/python/Makefile View File

@@ -28,7 +28,8 @@ HOST_BUILD_PARALLEL:=1
28 28
 PKG_BUILD_DIR:=$(BUILD_DIR)/Python-$(PKG_VERSION)
29 29
 HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/Python-$(PKG_VERSION)
30 30
 
31
-PKG_BUILD_DEPENDS:=libbz2/host python/host
31
+PKG_BUILD_DEPENDS:=python/host
32
+HOST_BUILD_DEPENDS:=bzip2/host
32 33
 
33 34
 include $(INCLUDE_DIR)/host-build.mk
34 35
 include $(INCLUDE_DIR)/package.mk