|
@@ -27,7 +27,7 @@ include $(INCLUDE_DIR)/package.mk
|
27
|
27
|
define Package/dovecot
|
28
|
28
|
SECTION:=mail
|
29
|
29
|
CATEGORY:=Mail
|
30
|
|
- DEPENDS:=+libopenssl +librt +zlib +libbz2 +libcap
|
|
30
|
+ DEPENDS:=+DOVECOT_LDAP:libopenldap +libopenssl +librt +zlib +libbz2 +libcap
|
31
|
31
|
TITLE:=An IMAP and POP3 daemon
|
32
|
32
|
MAINTAINER:=Peter Wagner <tripolar@gmx.at>
|
33
|
33
|
URL:=http://www.dovecot.org/
|
|
@@ -37,6 +37,17 @@ define Package/dovecot/description
|
37
|
37
|
Dovecot is a program which provides POP3 and IMAP services.
|
38
|
38
|
endef
|
39
|
39
|
|
|
40
|
+define Package/dovecot/config
|
|
41
|
+ menu "Select dovecot build options"
|
|
42
|
+ depends on PACKAGE_dovecot
|
|
43
|
+ config DOVECOT_LDAP
|
|
44
|
+ bool "LDAP support"
|
|
45
|
+ default y
|
|
46
|
+ help
|
|
47
|
+ Implements LDAP support in dovecot.
|
|
48
|
+ endmenu
|
|
49
|
+endef
|
|
50
|
+
|
40
|
51
|
CONFIGURE_ARGS += \
|
41
|
52
|
--without-gssapi \
|
42
|
53
|
--without-pam \
|
|
@@ -45,6 +56,14 @@ CONFIGURE_ARGS += \
|
45
|
56
|
--without-lzma \
|
46
|
57
|
--without-lz4
|
47
|
58
|
|
|
59
|
+ifneq ($(strip $(CONFIG_DOVECOT_LDAP)),)
|
|
60
|
+ CONFIGURE_ARGS+= \
|
|
61
|
+ --with-ldap=yes
|
|
62
|
+else
|
|
63
|
+ CONFIGURE_ARGS+= \
|
|
64
|
+ --with-ldap=no
|
|
65
|
+endif
|
|
66
|
+
|
48
|
67
|
CONFIGURE_VARS += \
|
49
|
68
|
RPCGEN= \
|
50
|
69
|
i_cv_signed_size_t=no \
|