Browse Source

perl-*: Update dependencies

All packages should now properly depend on all perlbase- and perl- packages
they need.

Signed-off-by: Marcel Denia <naoir@gmx.net>
Marcel Denia 9 years ago
parent
commit
9bf03cb1f5

+ 1
- 1
lang/perl-cgi/Makefile View File

@@ -29,7 +29,7 @@ define Package/perl-cgi
29 29
   CATEGORY:=Languages
30 30
   TITLE:=Handle Common Gateway Interface requests and responses
31 31
   URL:=http://search.cpan.org/dist/CGI/
32
-  DEPENDS:=perl +perl-html-parser +perlbase-essential +perlbase-if +perlbase-file +perlbase-encode +perlbase-config +perlbase-utf8 +perlbase-base +perl-cgi
32
+  DEPENDS:=perl +perl-html-parser +perlbase-base +perlbase-config +perlbase-encode +perlbase-essential +perlbase-file +perlbase-if +perlbase-utf8
33 33
 endef
34 34
 
35 35
 define Build/Configure

+ 2
- 2
lang/perl-compress-bzip2/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=perl-compress-bzip2
11 11
 PKG_VERSION:=2.22
12
-PKG_RELEASE:=3
12
+PKG_RELEASE:=4
13 13
 
14 14
 PKG_SOURCE_URL:=http://www.cpan.org/authors/id/R/RU/RURBAN/
15 15
 PKG_SOURCE:=Compress-Bzip2-$(PKG_VERSION).tar.gz
@@ -29,7 +29,7 @@ define Package/perl-compress-bzip2
29 29
   CATEGORY:=Languages
30 30
   TITLE:=Perl interface to bzip2 compression library
31 31
   URL:=http://search.cpan.org/dist/Compress-Bzip2/
32
-  DEPENDS:=perl +libbz2
32
+  DEPENDS:=perl +libbz2 +perlbase-autoloader +perlbase-config +perlbase-essential +perlbase-fcntl +perlbase-file +perlbase-getopt +perlbase-test +perlbase-xsloader
33 33
 endef
34 34
 
35 35
 define Build/Configure

+ 2
- 2
lang/perl-dbi/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=perl-dbi
11 11
 PKG_VERSION:=1.633
12
-PKG_RELEASE:=3
12
+PKG_RELEASE:=4
13 13
 
14 14
 PKG_SOURCE_URL:=http://www.cpan.org/authors/id/T/TI/TIMB/
15 15
 PKG_SOURCE:=DBI-$(PKG_VERSION).tar.gz
@@ -31,7 +31,7 @@ define Package/perl-dbi
31 31
   CATEGORY:=Languages
32 32
   TITLE:=Database independent interface for Perl
33 33
   URL:=http://search.cpan.org/dist/DBI/
34
-  DEPENDS:=perl +perlbase-essential
34
+  DEPENDS:=perl +perlbase-base +perlbase-config +perlbase-cwd +perlbase-data +perlbase-dynaloader +perlbase-errno +perlbase-essential +perlbase-fcntl +perlbase-file +perlbase-io +perlbase-ipc +perlbase-scalar +perlbase-storable +perlbase-symbol +perlbase-tie +perlbase-universal +perlbase-utf8
35 35
 endef
36 36
 
37 37
 define Build/Configure

+ 2
- 2
lang/perl-device-serialport/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=perl-device-serialport
11 11
 PKG_VERSION:=1.04
12
-PKG_RELEASE:=2
12
+PKG_RELEASE:=3
13 13
 
14 14
 PKG_SOURCE_URL:=http://www.cpan.org/authors/id/C/CO/COOK/
15 15
 PKG_SOURCE:=Device-SerialPort-$(PKG_VERSION).tar.gz
@@ -29,7 +29,7 @@ define Package/perl-device-serialport
29 29
   CATEGORY:=Languages
30 30
   TITLE:=A POSIX-based version of the Win32::SerialPort module
31 31
   URL:=http://search.cpan.org/dist/Device-SerialPort/
32
-  DEPENDS:=perl +perlbase-essential
32
+  DEPENDS:=perl +perlbase-essential +perlbase-io +perlbase-posix +perlbase-test +perlbase-xsloader
33 33
 endef
34 34
 
35 35
 define Package/perl-device-serialport/description

+ 1
- 1
lang/perl-encode-locale/Makefile View File

@@ -29,7 +29,7 @@ define Package/perl-encode-locale
29 29
   CATEGORY:=Languages
30 30
   TITLE:=Determine the locale encoding
31 31
   URL:=http://search.cpan.org/dist/Encode-Locale/
32
-  DEPENDS:=perl
32
+  DEPENDS:=perl +perlbase-base +perlbase-encode +perlbase-essential
33 33
 endef
34 34
 
35 35
 define Build/Configure

+ 1
- 1
lang/perl-file-listing/Makefile View File

@@ -29,7 +29,7 @@ define Package/perl-file-listing
29 29
   CATEGORY:=Languages
30 30
   TITLE:=Parse directory listing
31 31
   URL:=http://search.cpan.org/dist/File-Listing/
32
-  DEPENDS:=perl +perl-http-date
32
+  DEPENDS:=perl +perl-http-date +perlbase-essential
33 33
 endef
34 34
 
35 35
 define Build/Configure

+ 1
- 1
lang/perl-html-form/Makefile View File

@@ -29,7 +29,7 @@ define Package/perl-html-form
29 29
   CATEGORY:=Languages
30 30
   TITLE:=Class that represents an HTML form element
31 31
   URL:=http://search.cpan.org/dist/HTML-Form/
32
-  DEPENDS:=perl +perl-http-message +perlbase-encode +perl-uri +perl-html-parser +perlbase-essential
32
+  DEPENDS:=perl +perl-html-parser +perl-http-message +perl-uri +perlbase-encode +perlbase-essential
33 33
 endef
34 34
 
35 35
 define Build/Configure

+ 2
- 2
lang/perl-html-parser/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=perl-html-parser
11 11
 PKG_VERSION:=3.71
12
-PKG_RELEASE:=3
12
+PKG_RELEASE:=4
13 13
 
14 14
 PKG_SOURCE_URL:=http://www.cpan.org/authors/id/G/GA/GAAS/
15 15
 PKG_SOURCE:=HTML-Parser-$(PKG_VERSION).tar.gz
@@ -29,7 +29,7 @@ define Package/perl-html-parser
29 29
   CATEGORY:=Languages
30 30
   TITLE:=A collection of modules that parse HTML text documents
31 31
   URL:=http://search.cpan.org/dist/HTML-Parser/
32
-  DEPENDS:=perl +perl-html-tagset +perl-uri
32
+  DEPENDS:=perl +perl-html-tagset +perlbase-essential +perlbase-xsloader
33 33
 endef
34 34
 
35 35
 define Build/Configure

+ 2
- 2
lang/perl-html-tagset/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=perl-html-tagset
11 11
 PKG_VERSION:=3.20
12
-PKG_RELEASE:=2
12
+PKG_RELEASE:=3
13 13
 
14 14
 PKG_SOURCE_URL:=http://www.cpan.org/authors/id/P/PE/PETDANCE/
15 15
 PKG_SOURCE:=HTML-Tagset-$(PKG_VERSION).tar.gz
@@ -29,7 +29,7 @@ define Package/perl-html-tagset
29 29
   CATEGORY:=Languages
30 30
   TITLE:=Data tables pertaining to HTML
31 31
   URL:=http://search.cpan.org/dist/HTML-Tagset/
32
-  DEPENDS:=perl
32
+  DEPENDS:=perl +perlbase-essential
33 33
 endef
34 34
 
35 35
 define Build/Configure

+ 2
- 2
lang/perl-html-tree/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=perl-html-tree
11 11
 PKG_VERSION:=3.23
12
-PKG_RELEASE:=3
12
+PKG_RELEASE:=4
13 13
 PKG_MD5SUM:=6352f50be402301f79b580dd235d7762
14 14
 
15 15
 PKG_SOURCE_URL:=http://www.cpan.org/authors/id/P/PE/PETEK/
@@ -30,7 +30,7 @@ define Package/perl-html-tree
30 30
   CATEGORY:=Languages
31 31
   TITLE:=Represent and create HTML syntax trees
32 32
   URL:=http://search.cpan.org/dist/HTML-Tree/
33
-  DEPENDS:=perl +perl-html-parser +perl-html-tagset
33
+  DEPENDS:=perl +perl-html-parser +perl-html-tagset +perlbase-essential +perlbase-integer
34 34
 endef
35 35
 
36 36
 define Build/Configure

+ 1
- 1
lang/perl-http-cookies/Makefile View File

@@ -29,7 +29,7 @@ define Package/perl-http-cookies
29 29
   CATEGORY:=Languages
30 30
   TITLE:=HTTP cookie jars
31 31
   URL:=http://search.cpan.org/dist/HTTP-Cookies/
32
-  DEPENDS:=perl +perl-http-date +perl-http-message
32
+  DEPENDS:=perl +perl-http-date +perl-http-message +perlbase-essential +perlbase-time
33 33
 endef
34 34
 
35 35
 define Build/Configure

+ 1
- 1
lang/perl-http-daemon/Makefile View File

@@ -29,7 +29,7 @@ define Package/perl-http-daemon
29 29
   CATEGORY:=Languages
30 30
   TITLE:=A simple http server class
31 31
   URL:=http://search.cpan.org/dist/HTTP-Daemon/
32
-  DEPENDS:=perl +perl-http-message +perl-http-date +perl-lwp-mediatypes
32
+  DEPENDS:=perl +perl-http-date +perl-http-message +perl-lwp-mediatypes +perlbase-essential +perlbase-io +perlbase-sys
33 33
 endef
34 34
 
35 35
 define Build/Configure

+ 1
- 1
lang/perl-http-date/Makefile View File

@@ -29,7 +29,7 @@ define Package/perl-http-date
29 29
   CATEGORY:=Languages
30 30
   TITLE:=Date conversion routines
31 31
   URL:=http://search.cpan.org/dist/HTTP-Date/
32
-  DEPENDS:=perl
32
+  DEPENDS:=perl +perlbase-essential +perlbase-time
33 33
 endef
34 34
 
35 35
 define Build/Configure

+ 1
- 1
lang/perl-http-message/Makefile View File

@@ -29,7 +29,7 @@ define Package/perl-http-message
29 29
   CATEGORY:=Languages
30 30
   TITLE:=HTTP style messages
31 31
   URL:=http://search.cpan.org/dist/HTTP-Message/
32
-  DEPENDS:=perl
32
+  DEPENDS:=perl +perl-encode-locale +perl-http-date +perl-io-html +perl-lwp-mediatypes +perl-uri +perlbase-compress +perlbase-encode +perlbase-essential +perlbase-io +perlbase-mime
33 33
 endef
34 34
 
35 35
 define Build/Configure

+ 1
- 1
lang/perl-http-negotiate/Makefile View File

@@ -29,7 +29,7 @@ define Package/perl-http-negotiate
29 29
   CATEGORY:=Languages
30 30
   TITLE:=Choose a variant to serve
31 31
   URL:=http://search.cpan.org/dist/HTTP-Negotiate/
32
-  DEPENDS:=perl
32
+  DEPENDS:=perl +perl-http-message +perlbase-essential
33 33
 endef
34 34
 
35 35
 define Build/Configure

+ 1
- 1
lang/perl-http-server-simple/Makefile View File

@@ -29,7 +29,7 @@ define Package/perl-http-server-simple
29 29
   CATEGORY:=Languages
30 30
   TITLE:=Lightweight HTTP server
31 31
   URL:=http://search.cpan.org/dist/HTTP-Server-Simple/
32
-  DEPENDS:=perl +perlbase-socket +perl-cgi +perlbase-test +perlbase-essential +perlbase-filehandle +perlbase-base +perl-http-server-simple
32
+  DEPENDS:=perl +perl-cgi +perlbase-base +perlbase-essential +perlbase-filehandle +perlbase-socket +perlbase-test
33 33
 endef
34 34
 
35 35
 define Build/Configure

+ 1
- 1
lang/perl-io-html/Makefile View File

@@ -29,7 +29,7 @@ define Package/perl-io-html
29 29
   CATEGORY:=Languages
30 30
   TITLE:=Open an HTML file with automatic charset detection
31 31
   URL:=http://search.cpan.org/dist/IO-HTML/
32
-  DEPENDS:=perl +perlbase-essential +perlbase-encode
32
+  DEPENDS:=perl +perlbase-encode +perlbase-essential
33 33
 endef
34 34
 
35 35
 define Build/Configure

+ 2
- 2
lang/perl-lockfile-simple/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=perl-lockfile-simple
11 11
 PKG_VERSION:=0.208
12
-PKG_RELEASE:=2
12
+PKG_RELEASE:=3
13 13
 
14 14
 PKG_SOURCE_URL:=http://www.cpan.org/authors/id/S/SC/SCHWIGON/lockfile-simple/
15 15
 PKG_SOURCE:=LockFile-Simple-$(PKG_VERSION).tar.gz
@@ -29,7 +29,7 @@ define Package/perl-lockfile-simple
29 29
   CATEGORY:=Languages
30 30
   TITLE:=Simple advisory file locking
31 31
   URL:=http://search.cpan.org/dist/LockFile-Simple/
32
-  DEPENDS:=perl
32
+  DEPENDS:=perl +perlbase-essential +perlbase-sys
33 33
 endef
34 34
 
35 35
 define Build/Configure

+ 1
- 1
lang/perl-lwp-mediatypes/Makefile View File

@@ -29,7 +29,7 @@ define Package/perl-lwp-mediatypes
29 29
   CATEGORY:=Languages
30 30
   TITLE:=Guess media type for a file or a URL
31 31
   URL:=http://search.cpan.org/dist/LWP-MediaTypes/
32
-  DEPENDS:=perl
32
+  DEPENDS:=perl +perlbase-essential
33 33
 endef
34 34
 
35 35
 define Build/Configure

+ 1
- 1
lang/perl-net-http/Makefile View File

@@ -29,7 +29,7 @@ define Package/perl-net-http
29 29
   CATEGORY:=Languages
30 30
   TITLE:=Low-level HTTP connection (client)
31 31
   URL:=http://search.cpan.org/dist/Net-HTTP/
32
-  DEPENDS:=perl +perlbase-io +perl-uri +perlbase-compress +perlbase-essential +perl-net-http
32
+  DEPENDS:=perl +perl-uri +perlbase-compress +perlbase-essential +perlbase-io
33 33
 endef
34 34
 
35 35
 define Build/Configure

+ 2
- 2
lang/perl-net-telnet/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=perl-net-telnet
11 11
 PKG_VERSION:=3.04
12
-PKG_RELEASE:=2
12
+PKG_RELEASE:=3
13 13
 
14 14
 PKG_SOURCE_URL:=http://www.cpan.org/authors/id/J/JR/JROGERS/
15 15
 PKG_SOURCE:=Net-Telnet-$(PKG_VERSION).tar.gz
@@ -29,7 +29,7 @@ define Package/perl-net-telnet
29 29
   CATEGORY:=Languages
30 30
   TITLE:=Telnet client
31 31
   URL:=http://search.cpan.org/dist/Net-Telnet/
32
-  DEPENDS:=perl
32
+  DEPENDS:=perl +perlbase-essential +perlbase-socket +perlbase-symbol
33 33
 endef
34 34
 
35 35
 define Build/Configure

+ 2
- 2
lang/perl-test-harness/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=perl-test-harness
11 11
 PKG_VERSION:=3.35
12
-PKG_RELEASE:=2
12
+PKG_RELEASE:=3
13 13
 
14 14
 PKG_SOURCE_URL:=http://www.cpan.org/authors/id/L/LE/LEONT/
15 15
 PKG_SOURCE:=Test-Harness-$(PKG_VERSION).tar.gz
@@ -29,7 +29,7 @@ define Package/perl-test-harness
29 29
   CATEGORY:=Languages
30 30
   TITLE:=Perl Test Harness
31 31
   URL:=http://search.cpan.org/dist/Test-Harness/
32
-  DEPENDS:=perl
32
+  DEPENDS:=perl +perlbase-base +perlbase-benchmark +perlbase-config +perlbase-essential +perlbase-file +perlbase-getopt +perlbase-io +perlbase-posix +perlbase-text
33 33
 endef
34 34
 
35 35
 define Build/Configure

+ 1
- 1
lang/perl-test-warn/Makefile View File

@@ -29,7 +29,7 @@ define Package/perl-test-warn
29 29
   CATEGORY:=Languages
30 30
   TITLE:=Perl extension to test methods for warnings
31 31
   URL:=http://search.cpan.org/dist/Test-Warn/
32
-  DEPENDS:=perl +perlbase-test +perl-sub-uplevel +perlbase-essential
32
+  DEPENDS:=perl +perl-sub-uplevel +perlbase-essential +perlbase-test
33 33
 endef
34 34
 
35 35
 define Build/Configure

+ 1
- 1
lang/perl-uri/Makefile View File

@@ -29,7 +29,7 @@ define Package/perl-uri
29 29
   CATEGORY:=Languages
30 30
   TITLE:=Manipulates and accesses URI strings
31 31
   URL:=http://search.cpan.org/dist/URI/
32
-  DEPENDS:=perl
32
+  DEPENDS:=perl +perlbase-essential +perlbase-integer +perlbase-mime +perlbase-scalar +perlbase-utf8
33 33
 endef
34 34
 
35 35
 define Build/Configure

+ 2
- 2
lang/perl-www-curl/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=perl-www-curl
11 11
 PKG_VERSION:=4.17
12
-PKG_RELEASE:=3
12
+PKG_RELEASE:=4
13 13
 
14 14
 PKG_SOURCE_URL:=http://www.cpan.org/authors/id/S/SZ/SZBALINT/
15 15
 PKG_SOURCE:=WWW-Curl-$(PKG_VERSION).tar.gz
@@ -30,7 +30,7 @@ define Package/perl-www-curl
30 30
   CATEGORY:=Languages
31 31
   TITLE:=Perl bindings to libcurl
32 32
   URL:=http://search.cpan.org/dist/WWW-Curl/
33
-  DEPENDS:=perl +libcurl
33
+  DEPENDS:=perl +libcurl +perlbase-essential +perlbase-xsloader
34 34
 endef
35 35
 
36 36
 define Build/Configure

+ 1
- 1
lang/perl-www-mechanize/Makefile View File

@@ -29,7 +29,7 @@ define Package/perl-www-mechanize
29 29
   CATEGORY:=Languages
30 30
   TITLE:=Perl WWW Mechanize
31 31
   URL:=http://search.cpan.org/dist/WWW-Mechanize/
32
-  DEPENDS:=perl +perl-www
32
+  DEPENDS:=perl +perl-cgi +perl-html-form +perl-html-parser +perl-html-tree +perl-http-daemon +perl-http-message +perl-http-server-simple +perl-test-warn +perl-uri +perl-www +perlbase-base +perlbase-essential +perlbase-file +perlbase-findbin +perlbase-getopt +perlbase-pod +perlbase-test
33 33
 endef
34 34
 
35 35
 define Build/Configure

+ 1
- 1
lang/perl-www-robotrules/Makefile View File

@@ -29,7 +29,7 @@ define Package/perl-www-robotrules
29 29
   CATEGORY:=Languages
30 30
   TITLE:=database of robots.txt-derived permissions
31 31
   URL:=http://search.cpan.org/dist/WWW-RobotRules/
32
-  DEPENDS:=perl +perl-uri +perlbase-anydbm-file +perlbase-fcntl +perlbase-essential +perl-www-robotrules
32
+  DEPENDS:=perl +perl-uri +perlbase-anydbm-file +perlbase-essential +perlbase-fcntl
33 33
 endef
34 34
 
35 35
 define Build/Configure

+ 1
- 1
lang/perl-www/Makefile View File

@@ -29,7 +29,7 @@ define Package/perl-www
29 29
   CATEGORY:=Languages
30 30
   TITLE:=WWW client/server library for Perl (aka LWP)
31 31
   URL:=http://search.cpan.org/dist/libwww-perl/
32
-  DEPENDS:=perl +perl-html-parser +perl-html-tagset +perl-uri
32
+  DEPENDS:=perl +perl-encode-locale +perl-file-listing +perl-html-parser +perl-http-cookies +perl-http-daemon +perl-http-date +perl-http-message +perl-http-negotiate +perl-lwp-mediatypes +perl-net-http +perl-uri +perl-www-robotrules +perlbase-base +perlbase-digest +perlbase-encode +perlbase-essential +perlbase-io +perlbase-mime +perlbase-net
33 33
 endef
34 34
 
35 35
 define Build/Configure