Lars Gierth 10 years ago
parent
commit
9c37a78aae
1 changed files with 47 additions and 0 deletions
  1. 47
    0
      lang/dkjson/Makefile

+ 47
- 0
lang/dkjson/Makefile View File

@@ -0,0 +1,47 @@
1
+#
2
+# Copyright (C) 20013-2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=dkjson
11
+PKG_VERSION:=2.5
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:=http://dkolf.de/src/dkjson-lua.fsl/tarball/
16
+# TODO: md5sum doesn't seem be taken into account
17
+PKG_MD5SUM:=dbe706722dd64308172cf8e37395e762
18
+PKG_LICENSE:=MIT
19
+
20
+include $(INCLUDE_DIR)/package.mk
21
+
22
+define Package/dkjson
23
+	SUBMENU:=Lua
24
+	SECTION:=lang
25
+	CATEGORY:=Languages
26
+	TITLE:=DKJSON
27
+	URL:=http://dkolf.de/src/dkjson-lua.fsl/home
28
+	MAINTAINER:=Lars Gierth <larsg@systemli.org>
29
+	DEPENDS:=+lua
30
+endef
31
+
32
+define Package/dkjson/description
33
+	Lua JSON parser/serializer with UTF-8 support
34
+endef
35
+
36
+define Build/Configure
37
+endef
38
+
39
+define Build/Compile
40
+endef
41
+
42
+define Package/dkjson/install
43
+	$(INSTALL_DIR) $(1)/usr/lib/lua
44
+	$(INSTALL_BIN) $(BUILD_DIR)/dkjson/dkjson.lua $(1)/usr/lib/lua/
45
+endef
46
+
47
+$(eval $(call BuildPackage,dkjson))