Browse Source

ola: Update to 0.9.7.

Signed-off-by: Christian Beier <cb@shoutrlabs.com>
Christian Beier 9 years ago
parent
commit
9c418e5445
2 changed files with 17 additions and 2 deletions
  1. 2
    2
      net/ola/Makefile
  2. 15
    0
      net/ola/patches/001-include-endian_h.patch

+ 2
- 2
net/ola/Makefile View File

@@ -9,13 +9,13 @@
9 9
 include $(TOPDIR)/rules.mk
10 10
 
11 11
 PKG_NAME:=ola
12
-PKG_VERSION:=0.9.6
12
+PKG_VERSION:=0.9.7
13 13
 PKG_RELEASE:=1
14 14
 
15 15
 PKG_SOURCE_PROTO:=git
16 16
 PKG_SOURCE_URL:=https://github.com/OpenLightingProject/ola.git
17 17
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
18
-PKG_SOURCE_VERSION:=e9ece0540fb40beb1be33417cb7e0abf45af74e0
18
+PKG_SOURCE_VERSION:=2a306e4f0221fea9f4833ba04b042e72c6f10cd3
19 19
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
20 20
 PKG_LICENSE:=LGPL-2.1+
21 21
 

+ 15
- 0
net/ola/patches/001-include-endian_h.patch View File

@@ -0,0 +1,15 @@
1
+diff --git a/common/network/NetworkUtils.cpp b/common/network/NetworkUtils.cpp
2
+index 3914818..094a311 100644
3
+--- a/common/network/NetworkUtils.cpp
4
++++ b/common/network/NetworkUtils.cpp
5
+@@ -39,6 +39,10 @@ typedef uint32_t in_addr_t;
6
+ #include <resolv.h>
7
+ #endif
8
+ 
9
++#ifdef HAVE_ENDIAN_H
10
++#include <endian.h>
11
++#endif
12
++
13
+ #if defined(HAVE_LINUX_NETLINK_H) && defined(HAVE_LINUX_RTNETLINK_H)
14
+ #define USE_NETLINK_FOR_DEFAULT_ROUTE 1
15
+ #include <linux/netlink.h>