Browse Source

gnunet: improve packaging

some general packaging fixes for cadet and conversation.
allow building experimental components multicast, psyc, social.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Daniel Golle 9 years ago
parent
commit
9de00726ba
1 changed files with 13 additions and 7 deletions
  1. 13
    7
      net/gnunet/Makefile

+ 13
- 7
net/gnunet/Makefile View File

@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
10 10
 PKG_NAME:=gnunet
11 11
 PKG_SOURCE_VERSION:=36713
12 12
 PKG_VERSION:=0.10.1-svn$(PKG_SOURCE_VERSION)
13
-PKG_RELEASE:=1
13
+PKG_RELEASE:=2
14 14
 
15 15
 # ToDo:
16 16
 #  - break-out {peer,name,data}store for each backend
@@ -39,6 +39,7 @@ CONFIGURE_ARGS+= \
39 39
 	$(if $(CONFIG_PACKAGE_$(PKG_NAME)-mysql),--with-mysql="$(STAGING_DIR)/usr",--without-mysql) \
40 40
 	$(if $(CONFIG_PACKAGE_$(PKG_NAME)-pgsql),--with-postgresql="$(STAGING_DIR)/usr/bin/pg_config",--without-postgresql) \
41 41
 	$(if $(CONFIG_PACKAGE_$(PKG_NAME)-sqlite),--with-sqlite="$(STAGING_DIR)/usr",--without-sqlite) \
42
+	$(if $(CONFIG_PACKAGE_$(PKG_NAME)-experiments),--enable-experimental,--disable-experimental) \
42 43
 	--with-extractor=$(STAGING_DIR)/usr \
43 44
 	--with-gnutls=$(STAGING_DIR)/usr \
44 45
 	--with-libgnurl=$(STAGING_DIR)/usr \
@@ -131,7 +132,7 @@ define Package/gnunet/install
131 132
 	$(INSTALL_DIR) $(1)/usr/bin $(1)/usr/lib/gnunet/libexec
132 133
 	$(INSTALL_DIR) $(1)/usr/share/gnunet/config.d $(1)/usr/share/gnunet/hellos
133 134
 
134
-	( for bin in arm ats core config ecc identity nat-server nse \
135
+	( for bin in arm ats cadet core config ecc identity nat nat-server nse \
135 136
 	    peerinfo peerstore revocation scalarproduct statistics transport uri; do \
136 137
 		$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gnunet-$$$$bin $(1)/usr/bin/ ; \
137 138
 	done )
@@ -153,7 +154,8 @@ define Package/gnunet/install
153 154
 	    service-core service-dht service-identity service-nse \
154 155
 	    service-peerinfo service-peerstore service-regex \
155 156
 	    service-revocation service-scalarproduct-alice \
156
-	    service-scalarproduct-bob service-set service-statistics \
157
+	    service-scalarproduct-bob service-scalarproduct-ecc-alice \
158
+	    service-scalarproduct-ecc-bob service-set service-statistics \
157 159
 	    service-transport; do \
158 160
 		$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/gnunet/libexec/gnunet-$$$$lex $(1)/usr/lib/gnunet/libexec ; \
159 161
 	done )
@@ -184,7 +186,7 @@ DEPENDS_conversation:=+gnunet-gns +libgst1app +libgst1audio +libgstreamer1 +glib
184 186
 BIN_conversation:=conversation conversation-test
185 187
 LIB_conversation:=conversation microphone speaker
186 188
 PLUGIN_conversation:=gnsrecord_conversation
187
-LIBEXEC_conversation:=helper-audio-playback helper-audio-record
189
+LIBEXEC_conversation:=helper-audio-playback helper-audio-record service-conversation
188 190
 CONF_conversation:=conversation
189 191
 
190 192
 DEPENDS_transport-http_client:=+libgnurl
@@ -196,8 +198,12 @@ PLUGIN_transport-http_server:=transport_http_server transport_https_server
196 198
 PLUGIN_transport-wlan:=transport_wlan
197 199
 LIBEXEC_transport-wlan:=helper-transport-wlan
198 200
 
199
-DEPENDS_experiments:=+libglpk
200
-PLUGIN_experiments:=ats_mlp ats_ril
201
+DEPENDS_experiments:=+libglpk +gnunet-sqlite
202
+BIN_experiments:=multicast rps
203
+LIB_experiments:=consensus dv env multicast psyc psycstore psycutil rps secretsharing social
204
+PLUGIN_experiments:=ats_mlp ats_ril namecache_flat namestore_flat psycstore_sqlite transport_dv
205
+LIBEXEC_experiments:=service-consensus service-dv service-evil-consensus service-multicast service-psyc service-psycstore service-rps service-secretsharing service-social
206
+CONF_experiments:=consensus dv multicast psyc psycstore rps secretsharing social
201 207
 
202 208
 DEPENDS_fs:=+gnunet-datastore +libextractor
203 209
 BIN_fs:=auto-share directory download download-manager.scm fs publish unindex search
@@ -237,7 +243,7 @@ PLUGIN_transport-bluetooth:=transport_bluetooth
237 243
 LIBEXEC_transport-bluetooth:=helper-transport-bluetooth
238 244
 
239 245
 DEPENDS_utils:=+certtool +openssl-util
240
-BIN_utils:=gns-proxy-setup-ca transport-certificate-creation
246
+BIN_utils:=gns-proxy-setup-ca transport-certificate-creation scrypt
241 247
 
242 248
 DEPENDS_vpn:=+kmod-tun +iptables
243 249
 BIN_vpn:=vpn