|
@@ -0,0 +1,61 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2007-2014 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=cmdpad
|
|
11
|
+PKG_VERSION:=0.0.3
|
|
12
|
+PKG_RELEASE:=3
|
|
13
|
+
|
|
14
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
|
|
15
|
+PKG_SOURCE_URL:=@SF/cmdpad
|
|
16
|
+PKG_MD5SUM:=6633b2354b7f23f9cd8e2bfb6e735965
|
|
17
|
+
|
|
18
|
+PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
|
|
19
|
+PKG_LICENSE:=MIT
|
|
20
|
+PKG_LICENSE_FILE:=doc/COPYING
|
|
21
|
+
|
|
22
|
+include $(INCLUDE_DIR)/package.mk
|
|
23
|
+
|
|
24
|
+define Package/cmdpad
|
|
25
|
+ SECTION:=utils
|
|
26
|
+ CATEGORY:=Utilities
|
|
27
|
+ TITLE:=execute commands when a key is pressed, released or hold down
|
|
28
|
+ URL:=http://cmdpad.sourceforge.net/index.php
|
|
29
|
+endef
|
|
30
|
+
|
|
31
|
+CONFIGURE_ARGS += \
|
|
32
|
+ --enable-static \
|
|
33
|
+ --enable-shared
|
|
34
|
+
|
|
35
|
+define Package/cmdpad/description
|
|
36
|
+ cmdpad - execute commands when a key is pressed, released or hold down.
|
|
37
|
+ Should be started from /etc/rc or /etc/rc.local. To run it as deamon you
|
|
38
|
+ need to start it with '&'. All logs are printed to standard out and standard
|
|
39
|
+ error (to write the log to disk use cmdpad > /var/log/cmdpad). Cmdpad
|
|
40
|
+ searches for /etc/cmdpad.conf and load the key bindings. Then wait for
|
|
41
|
+ key event and check each command to see if it should be run.
|
|
42
|
+endef
|
|
43
|
+
|
|
44
|
+MAKE_FLAGS += \
|
|
45
|
+ $(TARGET_CONFIGURE_OPTS) \
|
|
46
|
+ $(1)
|
|
47
|
+
|
|
48
|
+define Package/cmdpad/install
|
|
49
|
+ $(INSTALL_DIR) $(1)/usr/sbin
|
|
50
|
+ $(INSTALL_DIR) $(1)/etc
|
|
51
|
+ $(INSTALL_DIR) $(1)/etc/init.d
|
|
52
|
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/cmdpad $(1)/usr/sbin/
|
|
53
|
+ $(INSTALL_CONF) $(PKG_BUILD_DIR)/src/cmdpad.conf $(1)/etc/
|
|
54
|
+ $(INSTALL_BIN) ./files/cmdpad.init $(1)/etc/init.d/cmdpad
|
|
55
|
+endef
|
|
56
|
+
|
|
57
|
+define Package/cmdpad/conffiles
|
|
58
|
+/etc/cmdpad.conf
|
|
59
|
+endef
|
|
60
|
+
|
|
61
|
+$(eval $(call BuildPackage,cmdpad))
|