Browse Source

python: add PKG_USE_MIPS16:=0 + handle CONFIG_USE_MIPS16

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Alexandru Ardelean 10 years ago
parent
commit
9e78aff770
1 changed files with 7 additions and 0 deletions
  1. 7
    0
      lang/python/files/python-package.mk

+ 7
- 0
lang/python/files/python-package.mk View File

@@ -30,6 +30,13 @@ define HostPython
30 30
 	)
31 31
 endef
32 32
 
33
+PKG_USE_MIPS16:=0
34
+# This is required in addition to PKG_USE_MIPS16:=0 because otherwise MIPS16
35
+# flags are inherited from the Python base package (via sysconfig module)
36
+ifdef CONFIG_USE_MIPS16
37
+  TARGET_CFLAGS += -mno-mips16 -mno-interlink-mips16
38
+endif
39
+
33 40
 define PyPackage
34 41
   $(call shexport,PyPackage/$(1)/filespec)
35 42