|
@@ -0,0 +1,57 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2015 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=sbc
|
|
11
|
+PKG_VERSION:=1.3
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
|
15
|
+PKG_SOURCE_URL:=https://www.kernel.org/pub/linux/bluetooth/
|
|
16
|
+PKG_MD5SUM:=2d8b7841f2c11ab287718d562f2b981c
|
|
17
|
+
|
|
18
|
+PKG_LICENSE:=LGPL-2.1+
|
|
19
|
+PKG_LICENSE_FILES:=COPYING.LIB
|
|
20
|
+PKG_MAINTAINER:=Dirk Neukirchen <dirkneukirchen@web.de>
|
|
21
|
+
|
|
22
|
+PKG_FIXUP:=autoreconf
|
|
23
|
+PKG_INSTALL:=1
|
|
24
|
+
|
|
25
|
+include $(INCLUDE_DIR)/package.mk
|
|
26
|
+
|
|
27
|
+define Package/sbc
|
|
28
|
+ SECTION:=libs
|
|
29
|
+ CATEGORY:=Libraries
|
|
30
|
+ TITLE:=sbc encoding library
|
|
31
|
+ DEPENDS:=+libsndfile
|
|
32
|
+ URL:=http://www.bluez.org
|
|
33
|
+endef
|
|
34
|
+
|
|
35
|
+define Package/sbc/description
|
|
36
|
+ Low Complexity Subband Coding for bluetooth audio profiles encoding and decoding.
|
|
37
|
+ Needed for A2DP support.
|
|
38
|
+endef
|
|
39
|
+
|
|
40
|
+define Build/InstallDev
|
|
41
|
+ $(INSTALL_DIR) $(1)/usr/include/sbc
|
|
42
|
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/sbc/sbc.h $(1)/usr/include/sbc/
|
|
43
|
+ $(INSTALL_DIR) $(1)/usr/lib
|
|
44
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsbc* $(1)/usr/lib/
|
|
45
|
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
|
|
46
|
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/sbc.pc $(1)/usr/lib/pkgconfig/
|
|
47
|
+endef
|
|
48
|
+
|
|
49
|
+define Package/sbc/install
|
|
50
|
+ $(INSTALL_DIR) $(1)/usr/bin
|
|
51
|
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/sbc* $(1)/usr/bin/
|
|
52
|
+ $(INSTALL_DIR) $(1)/usr/lib
|
|
53
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsbc.so* $(1)/usr/lib/
|
|
54
|
+endef
|
|
55
|
+
|
|
56
|
+
|
|
57
|
+$(eval $(call BuildPackage,sbc))
|