Przeglądaj źródła

git: update to 2.6.3

Signed-off-by: Luka Perkov <luka@openwrt.org>
Luka Perkov 9 lat temu
rodzic
commit
a150eb16f3

+ 4
- 3
net/git/Makefile Wyświetl plik

@@ -8,12 +8,12 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=git
11
-PKG_VERSION:=2.6.0
11
+PKG_VERSION:=2.6.3
12 12
 PKG_RELEASE:=1
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
15 15
 PKG_SOURCE_URL:=@KERNEL/software/scm/git/
16
-PKG_MD5SUM:=6b7d43d615fb3f0dfecf4d131e23f438
16
+PKG_MD5SUM:=5a6375349c3f13c8dbbabfc327bae429
17 17
 
18 18
 PKG_INSTALL:=1
19 19
 PKG_BUILD_PARALLEL:=1
@@ -83,7 +83,7 @@ endef
83 83
 
84 84
 define Package/git/install
85 85
 	$(INSTALL_DIR) $(1)/usr/bin
86
-	$(CP) $(PKG_INSTALL_DIR)/usr/bin/git   $(1)/usr/bin
86
+	$(CP) $(PKG_INSTALL_DIR)/usr/bin/git $(1)/usr/bin
87 87
 	$(RM) $(PKG_INSTALL_DIR)/usr/bin/git-cvsserver
88 88
 	$(CP) $(PKG_INSTALL_DIR)/usr/bin/git-* $(1)/usr/bin
89 89
 	$(INSTALL_DIR) $(1)/usr/lib/git-core
@@ -98,6 +98,7 @@ define Package/git/install
98 98
 		-cf - \
99 99
 		usr/lib/git-core \
100 100
 	) | ( cd $(1); $(TAR) -xf - )
101
+	$(INSTALL_DIR) $(1)/usr/share/git-core/templates
101 102
 endef
102 103
 
103 104
 define Package/git-http/install

+ 18
- 18
net/git/patches/100-convert_builtin.patch Wyświetl plik

@@ -1,6 +1,6 @@
1 1
 --- a/Makefile
2 2
 +++ b/Makefile
3
-@@ -549,16 +549,7 @@ EXTRA_PROGRAMS =
3
+@@ -557,16 +557,7 @@ EXTRA_PROGRAMS =
4 4
  # ... and all the rest that could be moved out of bindir to gitexecdir
5 5
  PROGRAMS += $(EXTRA_PROGRAMS)
6 6
  
@@ -17,9 +17,9 @@
17 17
  
18 18
  # Binary suffix, set to .exe for Windows builds
19 19
  X =
20
-@@ -907,6 +898,11 @@ BUILTIN_OBJS += builtin/verify-commit.o
21
- BUILTIN_OBJS += builtin/verify-pack.o
20
+@@ -923,6 +914,11 @@ BUILTIN_OBJS += builtin/verify-pack.o
22 21
  BUILTIN_OBJS += builtin/verify-tag.o
22
+ BUILTIN_OBJS += builtin/worktree.o
23 23
  BUILTIN_OBJS += builtin/write-tree.o
24 24
 +BUILTIN_OBJS += builtin/daemon.o
25 25
 +BUILTIN_OBJS += builtin/fast-import.o
@@ -29,7 +29,7 @@
29 29
  
30 30
  GITLIBS = $(LIB_FILE) $(XDIFF_LIB)
31 31
  EXTLIBS =
32
-@@ -1089,7 +1085,7 @@ endif
32
+@@ -1106,7 +1102,7 @@ endif
33 33
  EXTLIBS += -lz
34 34
  
35 35
  ifndef NO_OPENSSL
@@ -38,7 +38,7 @@
38 38
  	ifdef OPENSSLDIR
39 39
  		BASIC_CFLAGS += -I$(OPENSSLDIR)/include
40 40
  		OPENSSL_LINK = -L$(OPENSSLDIR)/$(lib) $(CC_LD_DYNPATH)$(OPENSSLDIR)/$(lib)
41
-@@ -1956,10 +1952,6 @@ endif
41
+@@ -1977,10 +1973,6 @@ endif
42 42
  git-%$X: %.o GIT-LDFLAGS $(GITLIBS)
43 43
  	$(QUIET_LINK)$(CC) $(ALL_CFLAGS) -o $@ $(ALL_LDFLAGS) $(filter %.o,$^) $(LIBS)
44 44
  
@@ -48,8 +48,8 @@
48 48
 -
49 49
  git-http-fetch$X: http.o http-walker.o http-fetch.o GIT-LDFLAGS $(GITLIBS)
50 50
  	$(QUIET_LINK)$(CC) $(ALL_CFLAGS) -o $@ $(ALL_LDFLAGS) $(filter %.o,$^) \
51
- 		$(LIBS) $(CURL_LIBCURL)
52
-@@ -2279,10 +2271,11 @@ endif
51
+ 		$(CURL_LIBCURL) $(LIBS)
52
+@@ -2300,10 +2292,11 @@ endif
53 53
  	bindir=$$(cd '$(DESTDIR_SQ)$(bindir_SQ)' && pwd) && \
54 54
  	execdir=$$(cd '$(DESTDIR_SQ)$(gitexec_instdir_SQ)' && pwd) && \
55 55
  	{ test "$$bindir/" = "$$execdir/" || \
@@ -64,7 +64,7 @@
64 64
  	} && \
65 65
 --- a/builtin.h
66 66
 +++ b/builtin.h
67
-@@ -138,5 +138,10 @@ extern int cmd_verify_pack(int argc, con
67
+@@ -141,5 +141,10 @@ extern int cmd_verify_pack(int argc, con
68 68
  extern int cmd_show_ref(int argc, const char **argv, const char *prefix);
69 69
  extern int cmd_pack_refs(int argc, const char **argv, const char *prefix);
70 70
  extern int cmd_replace(int argc, const char **argv, const char *prefix);
@@ -97,7 +97,7 @@
97 97
 +#include "../upload-pack.c"
98 98
 --- a/daemon.c
99 99
 +++ b/daemon.c
100
-@@ -1192,7 +1192,7 @@ static int serve(struct string_list *lis
100
+@@ -1184,7 +1184,7 @@ static int serve(struct string_list *lis
101 101
  	return service_loop(&socklist);
102 102
  }
103 103
  
@@ -106,8 +106,8 @@
106 106
  {
107 107
  	int listen_port = 0;
108 108
  	struct string_list listen_addr = STRING_LIST_INIT_NODUP;
109
-@@ -1388,12 +1388,13 @@ int main(int argc, char **argv)
110
- 		store_pid(pid_file);
109
+@@ -1380,12 +1380,13 @@ int main(int argc, char **argv)
110
+ 		write_file(pid_file, "%"PRIuMAX, (uintmax_t) getpid());
111 111
  
112 112
  	/* prepare argv for serving-processes */
113 113
 -	cld_argv = xmalloc(sizeof (char *) * (argc + 2));
@@ -127,7 +127,7 @@
127 127
  }
128 128
 --- a/fast-import.c
129 129
 +++ b/fast-import.c
130
-@@ -3351,7 +3351,7 @@ static void parse_argv(void)
130
+@@ -3380,7 +3380,7 @@ static void parse_argv(void)
131 131
  		read_marks();
132 132
  }
133 133
  
@@ -152,7 +152,7 @@
152 152
  {
153 153
  	int status, help;
154 154
  	struct stat st;
155
-@@ -395,6 +395,7 @@ static struct cmd_struct commands[] = {
155
+@@ -396,6 +396,7 @@ static struct cmd_struct commands[] = {
156 156
  	{ "config", cmd_config, RUN_SETUP_GENTLY },
157 157
  	{ "count-objects", cmd_count_objects, RUN_SETUP },
158 158
  	{ "credential", cmd_credential, RUN_SETUP_GENTLY },
@@ -160,7 +160,7 @@
160 160
  	{ "describe", cmd_describe, RUN_SETUP },
161 161
  	{ "diff", cmd_diff },
162 162
  	{ "diff-files", cmd_diff_files, RUN_SETUP | NEED_WORK_TREE },
163
-@@ -413,6 +414,7 @@ static struct cmd_struct commands[] = {
163
+@@ -414,6 +415,7 @@ static struct cmd_struct commands[] = {
164 164
  	{ "grep", cmd_grep, RUN_SETUP_GENTLY },
165 165
  	{ "hash-object", cmd_hash_object },
166 166
  	{ "help", cmd_help },
@@ -168,7 +168,7 @@
168 168
  	{ "index-pack", cmd_index_pack, RUN_SETUP_GENTLY },
169 169
  	{ "init", cmd_init_db, NO_SETUP },
170 170
  	{ "init-db", cmd_init_db, NO_SETUP },
171
-@@ -461,6 +463,7 @@ static struct cmd_struct commands[] = {
171
+@@ -463,6 +465,7 @@ static struct cmd_struct commands[] = {
172 172
  	{ "revert", cmd_revert, RUN_SETUP | NEED_WORK_TREE },
173 173
  	{ "rm", cmd_rm, RUN_SETUP },
174 174
  	{ "send-pack", cmd_send_pack, RUN_SETUP },
@@ -176,7 +176,7 @@
176 176
  	{ "shortlog", cmd_shortlog, RUN_SETUP_GENTLY | USE_PAGER },
177 177
  	{ "show", cmd_show, RUN_SETUP },
178 178
  	{ "show-branch", cmd_show_branch, RUN_SETUP },
179
-@@ -477,6 +480,7 @@ static struct cmd_struct commands[] = {
179
+@@ -479,6 +482,7 @@ static struct cmd_struct commands[] = {
180 180
  	{ "update-server-info", cmd_update_server_info, RUN_SETUP },
181 181
  	{ "upload-archive", cmd_upload_archive },
182 182
  	{ "upload-archive--writer", cmd_upload_archive_writer },
@@ -186,7 +186,7 @@
186 186
  	{ "verify-pack", cmd_verify_pack },
187 187
 --- a/imap-send.c
188 188
 +++ b/imap-send.c
189
-@@ -1492,7 +1492,7 @@ static int curl_append_msgs_to_imap(stru
189
+@@ -1496,7 +1496,7 @@ static int curl_append_msgs_to_imap(stru
190 190
  }
191 191
  #endif
192 192
  
@@ -208,7 +208,7 @@
208 208
  	const char **user_argv;
209 209
 --- a/upload-pack.c
210 210
 +++ b/upload-pack.c
211
-@@ -797,7 +797,7 @@ static int upload_pack_config(const char
211
+@@ -819,7 +819,7 @@ static int upload_pack_config(const char
212 212
  	return parse_hide_refs_config(var, value, "uploadpack");
213 213
  }
214 214
  

+ 3
- 3
net/git/patches/300-configure_for_crosscompiling Wyświetl plik

@@ -1,6 +1,6 @@
1 1
 --- a/configure.ac
2 2
 +++ b/configure.ac
3
-@@ -844,7 +844,8 @@ AC_RUN_IFELSE(
3
+@@ -867,7 +867,8 @@ AC_RUN_IFELSE(
4 4
  		FILE *f = fopen(".", "r");
5 5
  		return f && fread(&c, 1, 1, f)]])],
6 6
  	[ac_cv_fread_reads_directories=no],
@@ -10,7 +10,7 @@
10 10
  ])
11 11
  if test $ac_cv_fread_reads_directories = yes; then
12 12
  	FREAD_READS_DIRECTORIES=UnfortunatelyYes
13
-@@ -878,7 +879,8 @@ AC_RUN_IFELSE(
13
+@@ -901,7 +902,8 @@ AC_RUN_IFELSE(
14 14
  		  if (snprintf(buf, 3, "%s", "12345") != 5
15 15
  		      || strcmp(buf, "12")) return 1]])],
16 16
  	[ac_cv_snprintf_returns_bogus=no],
@@ -20,7 +20,7 @@
20 20
  ])
21 21
  if test $ac_cv_snprintf_returns_bogus = yes; then
22 22
  	SNPRINTF_RETURNS_BOGUS=UnfortunatelyYes
23
-@@ -901,7 +903,8 @@ yippeeyeswehaveit
23
+@@ -924,7 +926,8 @@ yippeeyeswehaveit
24 24
  #endif
25 25
  ]),
26 26
  	[ac_cv_sane_mode_bits=yes],

+ 2
- 2
net/git/patches/400-imapsend_without_curl.patch Wyświetl plik

@@ -1,8 +1,8 @@
1 1
 --- a/Makefile
2 2
 +++ b/Makefile
3
-@@ -1058,7 +1058,7 @@ else
3
+@@ -1074,7 +1074,7 @@ else
4 4
  	endif
5
- 	curl_check := $(shell (echo 072200; curl-config --vernum | sed -e '/^70[BC]/s/^/0/') 2>/dev/null | sort -r | sed -ne 2p)
5
+ 	curl_check := $(shell (echo 072200; $(CURL_CONFIG) --vernum | sed -e '/^70[BC]/s/^/0/') 2>/dev/null | sort -r | sed -ne 2p)
6 6
  	ifeq "$(curl_check)" "072200"
7 7
 -		USE_CURL_FOR_IMAP_SEND = YesPlease
8 8
 +#		USE_CURL_FOR_IMAP_SEND = YesPlease