Browse Source

luarocks: don't use github conflicting tag archives (#1051)

Signed-off-by: Nicolas Thill <nico@openwrt.org>
Nicolas Thill 9 years ago
parent
commit
a1bd5565d0
1 changed files with 6 additions and 2 deletions
  1. 6
    2
      lang/luarocks/Makefile

+ 6
- 2
lang/luarocks/Makefile View File

@@ -11,8 +11,12 @@ PKG_NAME:=luarocks
11 11
 PKG_VERSION:=2.2.0-rc1
12 12
 PKG_RELEASE:=2
13 13
 
14
-PKG_SOURCE:=v$(PKG_VERSION).tar.gz
15
-PKG_SOURCE_URL:=https://github.com/keplerproject/$(PKG_NAME)/archive/
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
15
+PKG_SOURCE_PROTO:=git
16
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
17
+PKG_SOURCE_URL:=https://github.com/keplerproject/luarocks.git
18
+PKG_SOURCE_VERSION:=v$(PKG_VERSION)
19
+
16 20
 PKG_MAINTAINER:=Amr Hassan <amr.hassan@gmail.com>
17 21
 PKG_INSTALL=1
18 22
 PKG_BUILD_DEPENDS:=lua/host luac/host