|
@@ -15,7 +15,7 @@ include $(TOPDIR)/rules.mk
|
15
|
15
|
|
16
|
16
|
PKG_NAME:=ruby
|
17
|
17
|
PKG_VERSION:=2.1.2
|
18
|
|
-PKG_RELEASE:=9
|
|
18
|
+PKG_RELEASE:=10
|
19
|
19
|
|
20
|
20
|
PKG_LIBVER:=2.1
|
21
|
21
|
|
|
@@ -321,6 +321,9 @@ define Package/ruby-core/install
|
321
|
321
|
$(1)/usr/lib/ruby/$(PKG_LIBVER)/webrick/ssl.rb \
|
322
|
322
|
\
|
323
|
323
|
$(1)/usr/lib/ruby/$(PKG_LIBVER)/*/dl.so \
|
|
324
|
+ $(1)/usr/lib/ruby/$(PKG_LIBVER)/dl.rb \
|
|
325
|
+ $(1)/usr/lib/ruby/$(PKG_LIBVER)/dl \
|
|
326
|
+ $(1)/usr/lib/ruby/$(PKG_LIBVER)/*/dl/ \
|
324
|
327
|
\
|
325
|
328
|
$(1)/usr/lib/ruby/$(PKG_LIBVER)/*/enc \
|
326
|
329
|
\
|
|
@@ -373,6 +376,7 @@ define Package/ruby-core/install
|
373
|
376
|
$(1)/usr/lib/ruby/$(PKG_LIBVER)/webrick.rb \
|
374
|
377
|
\
|
375
|
378
|
$(1)/usr/lib/ruby/$(PKG_LIBVER)/xmlrpc \
|
|
379
|
+ $(1)/usr/lib/ruby/$(PKG_LIBVER)/xmlrpc.rb \
|
376
|
380
|
\
|
377
|
381
|
$(1)/usr/lib/ruby/$(PKG_LIBVER)/yaml \
|
378
|
382
|
$(1)/usr/lib/ruby/$(PKG_LIBVER)/yaml.rb \
|
|
@@ -405,7 +409,10 @@ endef
|
405
|
409
|
|
406
|
410
|
define Package/ruby-dl/install
|
407
|
411
|
( cd $(PKG_INSTALL_DIR); $(TAR) -cf - \
|
|
412
|
+ usr/lib/ruby/$(PKG_LIBVER)/dl.rb \
|
|
413
|
+ usr/lib/ruby/$(PKG_LIBVER)/dl \
|
408
|
414
|
usr/lib/ruby/$(PKG_LIBVER)/*/dl.so \
|
|
415
|
+ usr/lib/ruby/$(PKG_LIBVER)/*/dl/ \
|
409
|
416
|
) | ( cd $(1); $(TAR) -xf - )
|
410
|
417
|
endef
|
411
|
418
|
|
|
@@ -583,6 +590,7 @@ endef
|
583
|
590
|
define Package/ruby-xmlrpc/install
|
584
|
591
|
$(INSTALL_DIR) $(1)/usr/lib/ruby/$(PKG_LIBVER)
|
585
|
592
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/ruby/$(PKG_LIBVER)/xmlrpc $(1)/usr/lib/ruby/$(PKG_LIBVER)/
|
|
593
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/ruby/$(PKG_LIBVER)/xmlrpc.rb $(1)/usr/lib/ruby/$(PKG_LIBVER)/
|
586
|
594
|
endef
|
587
|
595
|
|
588
|
596
|
define Package/ruby-yaml/install
|