|
@@ -8,14 +8,17 @@
|
8
|
8
|
include $(TOPDIR)/rules.mk
|
9
|
9
|
|
10
|
10
|
PKG_NAME:=mpd
|
11
|
|
-PKG_VERSION:=0.17.6
|
12
|
|
-PKG_RELEASE:=4
|
|
11
|
+PKG_VERSION:=0.18.11
|
|
12
|
+PKG_RELEASE:=1
|
13
|
13
|
|
14
|
|
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
15
|
|
-PKG_SOURCE_URL:=http://www.musicpd.org/download/mpd/0.17/
|
16
|
|
-PKG_MD5SUM:=0a42ed81ff298c12e22c16be31097e4c
|
|
14
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
|
15
|
+PKG_SOURCE_URL:=http://www.musicpd.org/download/mpd/0.18/
|
|
16
|
+PKG_MD5SUM:=be23120f342250e8352f6499cb960fd2
|
17
|
17
|
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
|
18
|
18
|
|
|
19
|
+PKG_LICENSE:=GPL-2.0
|
|
20
|
+PKG_LICENSE_FILE:=COPYING
|
|
21
|
+
|
19
|
22
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
|
20
|
23
|
PKG_BUILD_PARALLEL:=1
|
21
|
24
|
|
|
@@ -32,7 +35,7 @@ define Package/mpd/Default
|
32
|
35
|
CATEGORY:=Sound
|
33
|
36
|
TITLE:=Music Player Daemon
|
34
|
37
|
URL:=http://www.musicpd.org/
|
35
|
|
- DEPENDS:= +glib2 +libcurl +libpthread $(ICONV_DEPENDS) \
|
|
38
|
+ DEPENDS:= +glib2 +libcurl +libpthread +libmpdclient $(ICONV_DEPENDS) \
|
36
|
39
|
+libflac +BUILD_PATENTED:libmad +libvorbisidec
|
37
|
40
|
endef
|
38
|
41
|
|
|
@@ -98,6 +101,7 @@ CONFIGURE_ARGS += \
|
98
|
101
|
--disable-fluidsynth \
|
99
|
102
|
--disable-gme \
|
100
|
103
|
--enable-inotify \
|
|
104
|
+ --disable-eventfd \
|
101
|
105
|
--disable-iso9660 \
|
102
|
106
|
--disable-jack \
|
103
|
107
|
--disable-lame-encoder \
|
|
@@ -134,12 +138,8 @@ CONFIGURE_VARS += \
|
134
|
138
|
$(if $(CONFIG_BUILD_PATENTED),MAD_CFLAGS="$(TARGET_CFLAGS)") \
|
135
|
139
|
$(if $(CONFIG_BUILD_PATENTED),MAD_LIBS="$(TARGET_LDFLAGS) -lmad") \
|
136
|
140
|
|
137
|
|
-TARGET_CFLAGS += -std=gnu99
|
138
|
141
|
TARGET_LDFLAGS += -Wl,-rpath-link=$(STAGING_DIR)/usr/lib $(if $(ICONV_FULL),-liconv)
|
139
|
142
|
|
140
|
|
-# use gcc instead of g++ to avoid unnecessary linking against libstdc++
|
141
|
|
-TARGET_CXX:=$(TARGET_CC)
|
142
|
|
-
|
143
|
143
|
ifeq ($(BUILD_VARIANT),full)
|
144
|
144
|
|
145
|
145
|
CONFIGURE_ARGS += \
|