Kaynağa Gözat

haproxy: update to version 1.5.10

 - DOC: fix a few typos
 - BUG/MINOR: http: fix typo: "401 Unauthorized" => "407 Unauthorized"
 - BUG/MINOR: parse: refer curproxy instead of proxy
 - DOC: httplog does not support 'no'
 - MINOR: map/acl/dumpstats: remove the "Done." message
 - BUG/MEDIUM: sample: fix random number upper-bound
 - BUG/MEDIUM: patterns: previous fix was incomplete
 - BUG/MEDIUM: payload: ensure that a request channel is available
 - BUG/MINOR: tcp-check: don't condition data polling on check type
 - BUG/MEDIUM: tcp-check: don't rely on random memory contents
 - BUG/MEDIUM: tcp-checks: disable quick-ack unless next rule is an expect
 - BUG/MINOR: config: fix typo in condition when propagating process binding
 - BUG/MEDIUM: config: do not propagate processes between stopped processes
 - BUG/MAJOR: stream-int: properly check the memory allocation return
 - BUG/MEDIUM: memory: fix freeing logic in pool_gc2()
 - BUG/MEDIUM: compression: correctly report zlib_mem

Signed-off-by: Thomas Heil <heil@terminal-consulting.de>
Thomas Heil 10 yıl önce
ebeveyn
işleme
a393c6b021

+ 3
- 3
net/haproxy/Makefile Dosyayı Görüntüle

@@ -9,12 +9,12 @@
9 9
 include $(TOPDIR)/rules.mk
10 10
 
11 11
 PKG_NAME:=haproxy
12
-PKG_VERSION:=1.5.9
13
-PKG_RELEASE:=02
12
+PKG_VERSION:=1.5.10
13
+PKG_RELEASE:=00
14 14
 PKG_SOURCE:=haproxy-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=http://haproxy.1wt.eu/download/1.5/src/
16 16
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
17
-PKG_MD5SUM:=b7672bb6a8aa188a655b418f3c96f65c
17
+PKG_MD5SUM:=5631457ea1f84b3c0d8e5bc8015ed329
18 18
 PKG_MAINTAINER:=Thomas Heil <heil@terminal-consulting.de>
19 19
 PKG_LICENSE:=GPL-2.0
20 20
 

+ 0
- 33
net/haproxy/patches/0001-BUG-MEDIUM-patterns-previous-fix-was-incomplete.patch Dosyayı Görüntüle

@@ -1,34 +0,0 @@
1
-From bad3c6f1b6d776e5d9951a3b3054b4dce8922c54 Mon Sep 17 00:00:00 2001
2
-From: Willy Tarreau <w@1wt.eu>
3
-Date: Wed, 26 Nov 2014 13:17:03 +0100
4
-Subject: [PATCH 1/2] BUG/MEDIUM: patterns: previous fix was incomplete
5
-
6
-Dmitry Sivachenko <trtrmitya@gmail.com> reported that commit 315ec42
7
-("BUG/MEDIUM: pattern: don't load more than once a pattern list.")
8
-relies on an uninitialised variable in the stack. While it used to
9
-work fine during the tests, if the uninitialized variable is non-null,
10
-some patterns may be aggregated if loaded multiple times, resulting in
11
-slower processing, which was the original issue it tried to address.
12
-
13
-The fix needs to be backported to 1.5.
14
-(cherry picked from commit 4deaf39243c4d941998b1b0175bad05b8a287c0b)
15
----
16
- src/pattern.c | 2 +-
17
- 1 file changed, 1 insertion(+), 1 deletion(-)
18
-
19
-diff --git a/src/pattern.c b/src/pattern.c
20
-index 20547f9..208e33a 100644
21
---- a/src/pattern.c
22
-+++ b/src/pattern.c
23
-@@ -2096,7 +2096,7 @@ int pattern_read_from_file(struct pattern_head *head, unsigned int refflags,
24
- 	struct pat_ref *ref;
25
- 	struct pattern_expr *expr;
26
- 	struct pat_ref_elt *elt;
27
--	int reuse;
28
-+	int reuse = 0;
29
- 
30
- 	/* Lookup for the existing reference. */
31
- 	ref = pat_ref_lookup(filename);
32
-2.0.4
33
-

+ 0
- 48
net/haproxy/patches/0002-BUG-MEDIUM-payload-ensure-that-a-request-channel-is-.patch Dosyayı Görüntüle

@@ -1,49 +0,0 @@
1
-From 1e89acb6be9ba6400fe4defd3b6b2cc94c6667d9 Mon Sep 17 00:00:00 2001
2
-From: Willy Tarreau <w@1wt.eu>
3
-Date: Wed, 26 Nov 2014 13:24:24 +0100
4
-Subject: [PATCH 2/2] BUG/MEDIUM: payload: ensure that a request channel is
5
- available
6
-
7
-Denys Fedoryshchenko reported a segfault when using certain
8
-sample fetch functions in the "tcp-request connection" rulesets
9
-despite the warnings. This is because some tests for the existence
10
-of the channel were missing.
11
-
12
-The fetches which were fixed are :
13
-  - req.ssl_hello_type
14
-  - rep.ssl_hello_type
15
-  - req.ssl_sni
16
-
17
-This fix must be backported to 1.5.
18
-(cherry picked from commit 83f2592bcd2e186beeabcba16be16faaab82bd39)
19
----
20
- src/payload.c | 6 ++++++
21
- 1 file changed, 6 insertions(+)
22
-
23
-diff --git a/src/payload.c b/src/payload.c
24
-index 4057f6f..f62163c 100644
25
---- a/src/payload.c
26
-+++ b/src/payload.c
27
-@@ -72,6 +72,9 @@ smp_fetch_ssl_hello_type(struct proxy *px, struct session *s, void *l7, unsigned
28
- 
29
- 	chn = ((opt & SMP_OPT_DIR) == SMP_OPT_DIR_RES) ? s->rep : s->req;
30
- 
31
-+	if (!chn)
32
-+		goto not_ssl_hello;
33
-+
34
- 	bleft = chn->buf->i;
35
- 	data = (const unsigned char *)chn->buf->p;
36
- 
37
-@@ -276,6 +279,9 @@ smp_fetch_ssl_hello_sni(struct proxy *px, struct session *s, void *l7, unsigned
38
- 
39
- 	chn = ((opt & SMP_OPT_DIR) == SMP_OPT_DIR_RES) ? s->rep : s->req;
40
- 
41
-+	if (!chn)
42
-+		goto not_ssl_hello;
43
-+
44
- 	bleft = chn->buf->i;
45
- 	data = (unsigned char *)chn->buf->p;
46
- 
47
-2.0.4
48
-