Browse Source

procps-ng: import version 3.3.11

Signed-off-by: Gergely Kiss <mail.gery@gmail.com>
Gergely Kiss 9 years ago
parent
commit
a3b83067a9
1 changed files with 97 additions and 0 deletions
  1. 97
    0
      utils/procps-ng/Makefile

+ 97
- 0
utils/procps-ng/Makefile View File

@@ -0,0 +1,97 @@
1
+#
2
+# Copyright (C) 2006-2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=procps-ng
11
+PKG_VERSION:=3.3.11
12
+PKG_RELEASE:=1
13
+PKG_LICENSE:=GPL-2.0
14
+PKG_LICENSE_FILES:=COPYING COPYING.LIB
15
+
16
+PKG_SOURCE_PROTO:=git
17
+PKG_SOURCE_URL:=https://gitlab.com/procps-ng/procps.git
18
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
19
+PKG_SOURCE_VERSION:=de985eced583f18df273146b110491b0f7404aab
20
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
21
+
22
+PKG_BUILD_PARALLEL:=1
23
+PKG_INSTALL:=1
24
+
25
+include $(INCLUDE_DIR)/package.mk
26
+
27
+CONFIGURE_ARGS += --enable-skill
28
+
29
+PROCPS_APPLETS := \
30
+    free kill pgrep pkill pmap ps pwdx skill slabtop \
31
+    snice tload top uptime vmstat w watch
32
+
33
+define Package/procps-ng/Default
34
+  SECTION:=utils
35
+  CATEGORY:=Utilities
36
+  DEPENDS:=+libncurses
37
+  TITLE:=procps-ng utilities
38
+  URL:=https://gitlab.com/procps-ng/procps
39
+  MAINTAINER:=Gergely Kiss <mail.gery@gmail.com>
40
+endef
41
+
42
+define Build/Configure
43
+	(cd $(PKG_BUILD_DIR); echo "$(PKG_VERSION)" > "$(PKG_BUILD_DIR)/.tarball-version"; ./autogen.sh );
44
+	$(call Build/Configure/Default)
45
+endef
46
+
47
+define Package/procps-ng
48
+  $(call Package/procps-ng/Default)
49
+  MENU:=1
50
+endef
51
+
52
+define Package/procps-ng/description
53
+  procps is a set of command line and full-screen utilities that provide information out of the pseudo-filesystem
54
+  most commonly located at /proc. This filesystem provides a simple interface to the kernel data structures.
55
+  The programs of procps generally concentrate on the structures that describe the processess running on the system.
56
+
57
+  NOTE: some utilities provided by procps-ng packages (ps, uptime, kill, ...) are installed as busybox applets, by default.
58
+  Conflicting applets should be removed from the build to avoid file conflicts.
59
+endef
60
+
61
+define GenPlugin
62
+ define Package/$(1)
63
+   $(call Package/procps-ng/Default)
64
+   DEPENDS:=procps-ng
65
+   TITLE:=Applet $(2) from the procps-ng package
66
+   DEFAULT:=y
67
+ endef
68
+
69
+ define Package/$(1)/description
70
+  Installs the applet $(2).
71
+ endef
72
+endef
73
+
74
+$(foreach a,$(PROCPS_APPLETS),$(eval $(call GenPlugin,procps-ng-$(a),$(a))))
75
+
76
+MAKE_FLAGS += \
77
+	CFLAGS="$(TARGET_CFLAGS)" \
78
+	CPPFLAGS="$(TARGET_CPPFLAGS)" \
79
+	LDFLAGS="$(TARGET_LDFLAGS)" \
80
+
81
+define Package/procps-ng/install
82
+	$(INSTALL_DIR) $(1)/usr/bin
83
+	$(INSTALL_DIR) $(1)/usr/lib
84
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/libprocps.so* $(1)/usr/lib/
85
+endef
86
+
87
+define BuildPlugin
88
+  define Package/$(1)/install
89
+	$(INSTALL_DIR) $$(1)/usr/bin
90
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(2) $$(1)/usr/bin/
91
+  endef
92
+
93
+  $$(eval $$(call BuildPackage,$(1)))
94
+endef
95
+
96
+$(foreach a,$(PROCPS_APPLETS),$(eval $(call BuildPlugin,procps-ng-$(a),$(a))))
97
+$(eval $(call BuildPackage,procps-ng))