|
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
9
|
9
|
|
10
|
10
|
PKG_NAME:=python-psycopg2
|
11
|
11
|
PKG_VERSION:=2.6.1
|
12
|
|
-PKG_RELEASE:=1
|
|
12
|
+PKG_RELEASE:=2
|
13
|
13
|
PKG_MAINTAINER:=Dmitry Trefilov <the-alien@live.ru>
|
14
|
14
|
PKG_LICENSE:=LGPL-3.0+
|
15
|
15
|
PKG_LICENSE_FILES:=LICENSE
|
|
@@ -39,9 +39,10 @@ define Package/python-psycopg2/description
|
39
|
39
|
endef
|
40
|
40
|
|
41
|
41
|
define Build/Compile
|
42
|
|
- $(call Build/Compile/PyMod,.,build_py)
|
43
|
|
- $(call Build/Compile/PyMod,,build_ext --pg-config="$(STAGING_DIR)/usr/bin/pg_config")
|
44
|
|
- $(call Build/Compile/PyMod,.,install --prefix=/usr --root=$(PKG_INSTALL_DIR))
|
|
42
|
+ # The PATH var is required so that psycopg2's setup.py script finds pg_config
|
|
43
|
+ $(call Build/Compile/PyMod,., \
|
|
44
|
+ install --prefix=/usr --root=$(PKG_INSTALL_DIR), \
|
|
45
|
+ PATH=$(STAGING_DIR)/usr/bin:$(PATH))
|
45
|
46
|
endef
|
46
|
47
|
|
47
|
48
|
define Package/python-psycopg2/install
|