|
@@ -0,0 +1,52 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2014 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=libarchive
|
|
11
|
+PKG_VERSION:=3.1.2
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
15
|
+PKG_SOURCE_URL:=http://www.libarchive.org/downloads
|
|
16
|
+PKG_MD5SUM:=efad5a503f66329bb9d2f4308b5de98a
|
|
17
|
+PKG_MAINTAINER:=Johannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
|
|
18
|
+PKG_LICENSE:=BSD-2-Clause
|
|
19
|
+
|
|
20
|
+PKG_INSTALL:=1
|
|
21
|
+PKG_FIXUP:=autoreconf
|
|
22
|
+PKG_BUILD_DEPENDS:=libxml2 libopenssl zlib
|
|
23
|
+
|
|
24
|
+include $(INCLUDE_DIR)/package.mk
|
|
25
|
+
|
|
26
|
+define Package/libarchive/Default
|
|
27
|
+ SECTION:=libs
|
|
28
|
+ CATEGORY:=Libraries
|
|
29
|
+ URL:=http://www.libarchive.org
|
|
30
|
+endef
|
|
31
|
+
|
|
32
|
+define Package/libarchive
|
|
33
|
+ $(call Package/libarchive/Default)
|
|
34
|
+ DEPENDS:=+libxml2 +libopenssl +zlib
|
|
35
|
+ TITLE:=Multi-format archive and compression library
|
|
36
|
+endef
|
|
37
|
+
|
|
38
|
+define Package/libarchive/description
|
|
39
|
+ Multi-format archive and compression library.
|
|
40
|
+endef
|
|
41
|
+
|
|
42
|
+define Build/InstallDev
|
|
43
|
+ $(INSTALL_DIR) $(1)
|
|
44
|
+ $(CP) $(PKG_INSTALL_DIR)/* $(1)/
|
|
45
|
+endef
|
|
46
|
+
|
|
47
|
+define Package/libarchive/install
|
|
48
|
+ $(INSTALL_DIR) $(1)/usr/lib
|
|
49
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libarchive.so.* $(1)/usr/lib/
|
|
50
|
+endef
|
|
51
|
+
|
|
52
|
+$(eval $(call BuildPackage,libarchive))
|