Selaa lähdekoodia

Add gstreamer1 package

Signed-off-by: W. Michael Petullo <mike@flyn.org>
W. Michael Petullo 10 vuotta sitten
vanhempi
commit
a4ffe9bf9f

+ 190
- 0
multimedia/gstreamer1/Makefile Näytä tiedosto

@@ -0,0 +1,190 @@
1
+#
2
+# Copyright (C) 2008-2012 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=gstreamer1
11
+PKG_VERSION:=1.2.3
12
+PKG_RELEASE:=1
13
+PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
14
+
15
+PKG_BUILD_DIR:=$(BUILD_DIR)/gstreamer-$(PKG_VERSION)
16
+PKG_SOURCE:=gstreamer-$(PKG_VERSION).tar.xz
17
+PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gstreamer/
18
+PKG_MD5SUM:=8155b9c7574ccaa361cc504e8e0e72dc
19
+
20
+PKG_FIXUP:=autoreconf
21
+PKG_REMOVE_FILES:=autogen.sh aclocal.m4
22
+
23
+PKG_INSTALL:=1
24
+
25
+include $(INCLUDE_DIR)/package.mk
26
+include $(INCLUDE_DIR)/nls.mk
27
+
28
+define Package/gstreamer1/Default
29
+  CATEGORY:=Multimedia
30
+  SECTION:=multimedia
31
+  TITLE:=GStreamer
32
+  URL:=http://gstreamer.freedesktop.org/
33
+endef
34
+
35
+define Package/gstreamer1/description/Default
36
+ GStreamer open source multimedia framework
37
+endef
38
+
39
+
40
+define Package/gstreamer1
41
+$(call Package/gstreamer1/Default)
42
+  TITLE+= framework
43
+  DEPENDS+= +libgstreamer1 \
44
+	+libgst1check \
45
+	+libgst1controller \
46
+	+libgst1net
47
+endef
48
+
49
+define Package/gstreamer1/description
50
+$(call Package/gstreamer1/description/Default)
51
+ .
52
+ This meta package contains only dependencies on the other GStreamer
53
+ componenents.
54
+endef
55
+
56
+
57
+define Package/gstreamer1-utils
58
+$(call Package/gstreamer1/Default)
59
+  TITLE+= utilities
60
+  DEPENDS+= +libgstreamer1
61
+endef
62
+
63
+define Package/gstreamer1-utils/description
64
+$(call Package/gstreamer1/description/Default)
65
+ .
66
+ This package contains the GStreamer utilities.
67
+endef
68
+
69
+
70
+define Package/libgstreamer1
71
+$(call Package/gstreamer1/Default)
72
+  TITLE+= library (core)
73
+  DEPENDS+= +glib2 +libpthread +libxml2
74
+endef
75
+
76
+define Package/libgstreamer1/description
77
+$(call Package/gstreamer1/description/Default)
78
+ .
79
+ This package contains the GStreamer core library.
80
+endef
81
+  
82
+
83
+GST_VERSION:=1.0
84
+
85
+CONFIGURE_ARGS += \
86
+	--enable-static \
87
+	--disable-examples \
88
+	--disable-tests \
89
+	--disable-valgrind \
90
+	--without-libiconv-prefix \
91
+	--without-libintl-prefix \
92
+	--without-x \
93
+
94
+EXTRA_LDFLAGS+= \
95
+	-Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
96
+	-L$(ICONV_PREFIX)/lib -L$(INTL_PREFIX)/lib
97
+
98
+define Build/InstallDev
99
+	$(INSTALL_DIR) $(1)/usr/include/gstreamer-$(GST_VERSION)
100
+	( cd $(PKG_INSTALL_DIR); $(CP) \
101
+		./usr/include/gstreamer-$(GST_VERSION)/* \
102
+		$(1)/usr/include/gstreamer-$(GST_VERSION)/ \
103
+	)
104
+	$(INSTALL_DIR) $(1)/usr/lib
105
+	( cd $(PKG_INSTALL_DIR); $(CP) \
106
+		./usr/lib/libgst*-$(GST_VERSION).{a,la,so*} \
107
+		$(1)/usr/lib/ \
108
+	)
109
+	$(INSTALL_DIR) $(1)/usr/lib/gstreamer-$(GST_VERSION)
110
+	( cd $(PKG_INSTALL_DIR); $(CP) \
111
+		./usr/lib/gstreamer-$(GST_VERSION)/libgst*.{la,so} \
112
+		$(1)/usr/lib/gstreamer-$(GST_VERSION)/ \
113
+	)
114
+	$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
115
+	( cd $(PKG_INSTALL_DIR); $(CP) \
116
+		./usr/lib/pkgconfig/gstreamer*-$(GST_VERSION).pc \
117
+		$(1)/usr/lib/pkgconfig/ \
118
+	)
119
+	$(INSTALL_DIR) $(2)/share/aclocal
120
+	( cd $(PKG_INSTALL_DIR); $(CP) \
121
+		./usr/share/aclocal/* \
122
+		$(2)/share/aclocal/ \
123
+	)
124
+endef
125
+
126
+define Package/gstreamer1/install
127
+	/bin/true
128
+endef
129
+
130
+define Package/gstreamer1-utils/install
131
+	$(INSTALL_DIR) $(1)/usr/bin
132
+	( cd $(PKG_INSTALL_DIR); $(CP) \
133
+		./usr/bin/gst-launch* \
134
+		./usr/bin/gst-inspect* \
135
+		./usr/bin/gst-typefind* \
136
+		$(1)/usr/bin/ \
137
+	)
138
+endef
139
+
140
+define Package/libgstreamer1/install
141
+	$(INSTALL_DIR) $(1)/usr/lib
142
+	( cd $(PKG_INSTALL_DIR); $(CP) \
143
+		./usr/lib/libgstbase-$(GST_VERSION).so.* \
144
+		./usr/lib/libgstreamer-$(GST_VERSION).so.* \
145
+		$(1)/usr/lib/ \
146
+	)
147
+	$(INSTALL_DIR) $(1)/usr/lib/gstreamer-$(GST_VERSION)
148
+	( cd $(PKG_INSTALL_DIR); $(CP) \
149
+		./usr/lib/gstreamer-$(GST_VERSION)/libgst*.so \
150
+		$(1)/usr/lib/gstreamer-$(GST_VERSION)/ \
151
+	)
152
+endef
153
+
154
+
155
+# 1: short name
156
+# 2: description
157
+# 3: dependencies on other gstreamer libraries (short name)
158
+# 4: dependencies on other packages
159
+define GstBuildLibrary
160
+
161
+  define Package/libgst1$(1)
162
+    $(call Package/gstreamer1/Default)
163
+    TITLE+= $(2) library (core)
164
+    DEPENDS+= +libgstreamer1 $$(foreach p,$(3),+libgst1$$(p)) $(4)
165
+  endef
166
+
167
+  define Package/libgst1$(1)/description
168
+   $(call Package/gstreamer1/description/Default)
169
+   .
170
+   This package contains the GStreamer $(2) library.
171
+  endef
172
+
173
+  define Package/libgst1$(1)/install
174
+	$(INSTALL_DIR) $$(1)/usr/lib
175
+	( cd $(PKG_INSTALL_DIR); $(CP) \
176
+		./usr/lib/libgst$(1)-$(GST_VERSION).so.* \
177
+		$$(1)/usr/lib/ \
178
+	)
179
+  endef
180
+
181
+  $$(eval $$(call BuildPackage,libgst1$(1)))
182
+endef
183
+
184
+$(eval $(call GstBuildLibrary,check,check unit testing))
185
+$(eval $(call GstBuildLibrary,controller,dynamic parameter control))
186
+$(eval $(call GstBuildLibrary,net,network classes))
187
+
188
+$(eval $(call BuildPackage,libgstreamer1))
189
+$(eval $(call BuildPackage,gstreamer1))
190
+$(eval $(call BuildPackage,gstreamer1-utils))

+ 37
- 0
multimedia/gstreamer1/patches/001-no_docs.patch Näytä tiedosto

@@ -0,0 +1,37 @@
1
+diff -u --recursive gstreamer-1.0.7-vanilla/Makefile.am gstreamer-1.0.7/Makefile.am
2
+--- gstreamer-1.0.7-vanilla/Makefile.am	2013-06-01 18:47:44.498057069 -0500
3
++++ gstreamer-1.0.7/Makefile.am	2013-06-01 19:01:41.634143861 -0500
4
+@@ -8,7 +8,6 @@
5
+ 
6
+ SUBDIRS = pkgconfig \
7
+ 	gst libs plugins tests \
8
+-	docs \
9
+ 	po \
10
+ 	m4 \
11
+ 	common
12
+@@ -20,7 +19,6 @@
13
+ # These are all the possible subdirs
14
+ DIST_SUBDIRS = pkgconfig \
15
+ 	gst libs plugins tools tests \
16
+-	docs \
17
+ 	po \
18
+ 	m4 \
19
+ 	common
20
+diff -u --recursive gstreamer-1.0.7-vanilla/Makefile.in gstreamer-1.0.7/Makefile.in
21
+--- gstreamer-1.0.7-vanilla/Makefile.in	2013-06-01 18:47:44.533056863 -0500
22
++++ gstreamer-1.0.7/Makefile.in	2013-06-01 19:02:04.529246907 -0500
23
+@@ -508,13 +508,12 @@
24
+ DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --enable-docbook
25
+ aclocaldir = $(datadir)/aclocal
26
+ aclocal_DATA = gst-element-check-@GST_API_VERSION@.m4
27
+-SUBDIRS = pkgconfig gst libs plugins tests docs po m4 common \
28
++SUBDIRS = pkgconfig gst libs plugins tests po m4 common \
29
+ 	$(am__append_1)
30
+ 
31
+ # These are all the possible subdirs
32
+ DIST_SUBDIRS = pkgconfig \
33
+ 	gst libs plugins tools tests \
34
+-	docs \
35
+ 	po \
36
+ 	m4 \
37
+ 	common

+ 39
- 0
multimedia/gstreamer1/patches/002-no_tests.patch Näytä tiedosto

@@ -0,0 +1,39 @@
1
+diff -u --recursive gstreamer-1.0.7-vanilla/Makefile.am gstreamer-1.0.7/Makefile.am
2
+--- gstreamer-1.0.7-vanilla/Makefile.am	2013-06-01 19:22:31.546496381 -0500
3
++++ gstreamer-1.0.7/Makefile.am	2013-06-01 19:20:38.141070908 -0500
4
+@@ -7,7 +7,7 @@
5
+ aclocal_DATA = gst-element-check-@GST_API_VERSION@.m4
6
+ 
7
+ SUBDIRS = pkgconfig \
8
+-	gst libs plugins tests \
9
++	gst libs plugins \
10
+ 	po \
11
+ 	m4 \
12
+ 	common
13
+@@ -18,7 +18,7 @@
14
+ 
15
+ # These are all the possible subdirs
16
+ DIST_SUBDIRS = pkgconfig \
17
+-	gst libs plugins tools tests \
18
++	gst libs plugins tools \
19
+ 	po \
20
+ 	m4 \
21
+ 	common
22
+diff -u --recursive gstreamer-1.0.7-vanilla/Makefile.in gstreamer-1.0.7/Makefile.in
23
+--- gstreamer-1.0.7-vanilla/Makefile.in	2013-06-01 19:22:31.547496342 -0500
24
++++ gstreamer-1.0.7/Makefile.in	2013-06-01 19:20:48.948632307 -0500
25
+@@ -508,12 +508,12 @@
26
+ DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --enable-docbook
27
+ aclocaldir = $(datadir)/aclocal
28
+ aclocal_DATA = gst-element-check-@GST_API_VERSION@.m4
29
+-SUBDIRS = pkgconfig gst libs plugins tests po m4 common \
30
++SUBDIRS = pkgconfig gst libs plugins po m4 common \
31
+ 	$(am__append_1)
32
+ 
33
+ # These are all the possible subdirs
34
+ DIST_SUBDIRS = pkgconfig \
35
+-	gst libs plugins tools tests \
36
++	gst libs plugins tools \
37
+ 	po \
38
+ 	m4 \
39
+ 	common

+ 48
- 0
multimedia/gstreamer1/patches/003-no_translations.patch Näytä tiedosto

@@ -0,0 +1,48 @@
1
+diff -u --recursive gstreamer-1.0.7-vanilla/configure.ac gstreamer-1.0.7/configure.ac
2
+--- gstreamer-1.0.7-vanilla/configure.ac	2013-06-01 18:47:44.506057110 -0500
3
++++ gstreamer-1.0.7/configure.ac	2013-06-01 19:24:05.035756124 -0500
4
+@@ -769,7 +769,6 @@
5
+ libs/gst/net/Makefile
6
+ plugins/Makefile
7
+ plugins/elements/Makefile
8
+-po/Makefile.in
9
+ tests/Makefile
10
+ tests/benchmarks/Makefile
11
+ tests/check/Makefile
12
+diff -u --recursive gstreamer-1.0.7-vanilla/Makefile.am gstreamer-1.0.7/Makefile.am
13
+--- gstreamer-1.0.7-vanilla/Makefile.am	2013-06-01 19:23:08.361020919 -0500
14
++++ gstreamer-1.0.7/Makefile.am	2013-06-01 19:24:15.036357308 -0500
15
+@@ -8,7 +8,6 @@
16
+ 
17
+ SUBDIRS = pkgconfig \
18
+ 	gst libs plugins \
19
+-	po \
20
+ 	m4 \
21
+ 	common
22
+ 
23
+@@ -19,7 +18,6 @@
24
+ # These are all the possible subdirs
25
+ DIST_SUBDIRS = pkgconfig \
26
+ 	gst libs plugins tools \
27
+-	po \
28
+ 	m4 \
29
+ 	common
30
+ 
31
+diff -u --recursive gstreamer-1.0.7-vanilla/Makefile.in gstreamer-1.0.7/Makefile.in
32
+--- gstreamer-1.0.7-vanilla/Makefile.in	2013-06-01 19:23:08.362020867 -0500
33
++++ gstreamer-1.0.7/Makefile.in	2013-06-01 19:24:27.907844191 -0500
34
+@@ -508,13 +508,12 @@
35
+ DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --enable-docbook
36
+ aclocaldir = $(datadir)/aclocal
37
+ aclocal_DATA = gst-element-check-@GST_API_VERSION@.m4
38
+-SUBDIRS = pkgconfig gst libs plugins po m4 common \
39
++SUBDIRS = pkgconfig gst libs plugins m4 common \
40
+ 	$(am__append_1)
41
+ 
42
+ # These are all the possible subdirs
43
+ DIST_SUBDIRS = pkgconfig \
44
+ 	gst libs plugins tools \
45
+-	po \
46
+ 	m4 \
47
+ 	common
48
+