Преглед изворни кода

libxml2: Fix zlib detection the right way

The previous fix (#557) forced -lz into LDFLAGS instead of fixing the
real issue where configure was failing to detect zlib in the first
place. This was happening because it was looking in /lib, resulting in
conflicts with the host libraries.

Signed-off-by: James Le Cuirot <james.le-cuirot@yakara.com>
James Le Cuirot пре 10 година
родитељ
комит
a540959020
1 измењених фајлова са 1 додато и 2 уклоњено
  1. 1
    2
      libs/libxml2/Makefile

+ 1
- 2
libs/libxml2/Makefile Прегледај датотеку

@@ -42,7 +42,6 @@ define Package/libxml2/description
42 42
 endef
43 43
 
44 44
 TARGET_CFLAGS += $(FPIC)
45
-TARGET_LDFLAGS += -lz
46 45
 
47 46
 CONFIGURE_ARGS += \
48 47
 	--enable-shared \
@@ -73,7 +72,7 @@ CONFIGURE_ARGS += \
73 72
 	--with-xinclude \
74 73
 	--with-xpath \
75 74
 	--with-xptr \
76
-	--with-zlib \
75
+	--with-zlib=$(STAGING_DIR)/usr \
77 76
 	--without-lzma
78 77
 
79 78
 HOST_CONFIGURE_ARGS += \