Browse Source

net: mosquitto: Bump to 1.4 release

Of particular note, this adds optional support for websockets. This
defaults to enabled, as it's the biggest new feature in this release.
A config item is provided to disable it for manual use.

Full release notes: http://mosquitto.org/2015/02/version-1-4-released/

This also remove some build workarounds that are no longer required for
newer versions of mosquitto.

Signed-off-by: Karl Palsson <karlp@remake.is>
Karl Palsson 9 years ago
parent
commit
a584b3efe8
2 changed files with 15 additions and 4 deletions
  1. 6
    0
      net/mosquitto/Config.in
  2. 9
    4
      net/mosquitto/Makefile

+ 6
- 0
net/mosquitto/Config.in View File

@@ -0,0 +1,6 @@
1
+config MOSQUITTO_LWS
2
+    bool "libwebsockets support"
3
+    depends on PACKAGE_mosquitto
4
+    default y
5
+    help
6
+        Includes websockets support in the broker, via libwebsockets

+ 9
- 4
net/mosquitto/Makefile View File

@@ -9,19 +9,20 @@
9 9
 include $(TOPDIR)/rules.mk
10 10
 
11 11
 PKG_NAME:=mosquitto
12
-PKG_VERSION:=1.3.5
12
+PKG_VERSION:=1.4
13 13
 PKG_RELEASE:=1
14 14
 PKG_LICENSE:=BSD-3-Clause
15 15
 PKG_LICENSE_FILES:=LICENSE.txt
16 16
 
17 17
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
18 18
 PKG_SOURCE_URL:=http://mosquitto.org/files/source/
19
-PKG_MD5SUM:=55094ad4dc7c7985377f43d4fc3d09da
19
+PKG_MD5SUM:=cd879f5964311501ba8e2275add71484
20 20
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
21 21
 
22 22
 include $(INCLUDE_DIR)/package.mk
23 23
 
24
-MAKE_FLAGS+=WITH_MEMORY_TRACKING=no
24
+MAKE_FLAGS+=WITH_DOCS=no
25
+MAKE_FLAGS+=WITH_WEBSOCKETS=$(if $(CONFIG_MOSQUITTO_LWS),"yes","no")
25 26
 
26 27
 define Package/$(PKG_NAME)/default
27 28
   SECTION:=net
@@ -36,7 +37,7 @@ endef
36 37
 define Package/$(PKG_NAME)
37 38
     $(call Package/mosquitto/default)
38 39
     TITLE+= (with SSL support)
39
-    DEPENDS+= +libopenssl
40
+    DEPENDS+= +libopenssl +MOSQUITTO_LWS:libwebsockets-openssl
40 41
     VARIANT:=ssl
41 42
 endef
42 43
 
@@ -46,6 +47,10 @@ define Package/$(PKG_NAME)-nossl
46 47
     VARIANT:=nossl
47 48
 endef
48 49
 
50
+define Package/$(PKG_NAME)/config
51
+	source "$(SOURCE)/Config.in"
52
+endef
53
+
49 54
 define Package/$(PKG_NAME)/default/description
50 55
 Mosquitto is an open source (BSD licensed) message broker that implements
51 56
 the MQTT protocol version 3.1 and 3.1.1. MQTT provides a lightweight