|
@@ -0,0 +1,80 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2007-2008 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=bzip2
|
|
11
|
+PKG_VERSION:=1.0.6
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
15
|
+PKG_SOURCE_URL:=http://www.bzip.org/$(PKG_VERSION)
|
|
16
|
+PKG_MD5SUM:=00b516f4704d4a7cb50a1d97e6e8e15b
|
|
17
|
+PKG_MAINTAINER:=Steven Barth <cyrus@openwrt.org>
|
|
18
|
+
|
|
19
|
+PKG_LICENSE:=BZIP2
|
|
20
|
+PKG_LICENSE_FILES:=LICENSE
|
|
21
|
+
|
|
22
|
+include $(INCLUDE_DIR)/package.mk
|
|
23
|
+
|
|
24
|
+define Package/libbz2
|
|
25
|
+ SECTION:=libs
|
|
26
|
+ CATEGORY:=Libraries
|
|
27
|
+ DEPENDS:=
|
|
28
|
+ TITLE:=bzip2 library.
|
|
29
|
+ URL:=http://www.bzip.org/
|
|
30
|
+endef
|
|
31
|
+
|
|
32
|
+define Package/libbz2/description
|
|
33
|
+ bzip2 is a freely available, patent free, high-quality
|
|
34
|
+ data compressor. This packages provides libbz2 library.
|
|
35
|
+endef
|
|
36
|
+
|
|
37
|
+define Package/bzip2
|
|
38
|
+ SECTION:=utils
|
|
39
|
+ CATEGORY:=Utilities
|
|
40
|
+ DEPENDS:=+libbz2
|
|
41
|
+ TITLE:=bzip2 is a compression utility.
|
|
42
|
+ URL:=http://www.bzip.org/
|
|
43
|
+endef
|
|
44
|
+
|
|
45
|
+define Package/bzip2/description
|
|
46
|
+ bzip2 is a freely available, patent free, high-quality
|
|
47
|
+ data compressor. This package provides the binary.
|
|
48
|
+endef
|
|
49
|
+
|
|
50
|
+TARGET_CFLAGS += $(FPIC)
|
|
51
|
+CONFIGURE_ARGS += --prefix=/usr
|
|
52
|
+
|
|
53
|
+MAKE_FLAGS += \
|
|
54
|
+ -f Makefile-libbz2_so \
|
|
55
|
+ CFLAGS="$(TARGET_CFLAGS)" \
|
|
56
|
+ LDFLAGS="$(TARGET_LDLAGS)" \
|
|
57
|
+ all
|
|
58
|
+
|
|
59
|
+define Build/InstallDev
|
|
60
|
+ $(INSTALL_DIR) $(1)/usr/include
|
|
61
|
+ $(CP) $(PKG_BUILD_DIR)/bzlib.h $(1)/usr/include/
|
|
62
|
+ $(INSTALL_DIR) $(1)/usr/lib
|
|
63
|
+ $(CP) $(PKG_BUILD_DIR)/libbz2.so.$(PKG_VERSION) $(1)/usr/lib/
|
|
64
|
+ $(LN) libbz2.so.$(PKG_VERSION) $(1)/usr/lib/libbz2.so.1.0
|
|
65
|
+ $(LN) libbz2.so.$(PKG_VERSION) $(1)/usr/lib/libbz2.so
|
|
66
|
+endef
|
|
67
|
+
|
|
68
|
+define Package/libbz2/install
|
|
69
|
+ $(INSTALL_DIR) $(1)/usr/lib/
|
|
70
|
+ $(CP) $(PKG_BUILD_DIR)/libbz2.so.$(PKG_VERSION) $(1)/usr/lib/
|
|
71
|
+ $(LN) libbz2.so.$(PKG_VERSION) $(1)/usr/lib/libbz2.so.1.0
|
|
72
|
+endef
|
|
73
|
+
|
|
74
|
+define Package/bzip2/install
|
|
75
|
+ $(INSTALL_DIR) $(1)/usr/bin/
|
|
76
|
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/bzip2-shared $(1)/usr/bin/bzip2
|
|
77
|
+endef
|
|
78
|
+
|
|
79
|
+$(eval $(call BuildPackage,libbz2))
|
|
80
|
+$(eval $(call BuildPackage,bzip2))
|