Browse Source

Revert "avahi: remove dbus support for now"

This reverts commit c1675e2bc5.
Steven Barth 10 years ago
parent
commit
a689d930f1
1 changed files with 28 additions and 28 deletions
  1. 28
    28
      libs/avahi/Makefile

+ 28
- 28
libs/avahi/Makefile View File

@@ -26,7 +26,7 @@ PKG_SOURCE_URL:=http://avahi.org/download/
26 26
 PKG_MD5SUM:=2f22745b8f7368ad5a0a3fddac343f2d
27 27
 PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
28 28
 
29
-PKG_BUILD_DEPENDS:=libexpat libdaemon libgdbm intltool/host libpthread
29
+PKG_BUILD_DEPENDS:=libexpat libdaemon libgdbm intltool/host libpthread dbus
30 30
 
31 31
 PKG_FIXUP:=autoreconf
32 32
 PKG_REMOVE_FILES:=autogen.sh
@@ -132,28 +132,28 @@ $(call Package/avahi/Default/description)
132 132
  in a DHCP-like fashion. Especially useful on IPv6.
133 133
 endef
134 134
 
135
-#define Package/libavahi-dbus-support
136
-#  $(call Package/avahi/Default)
137
-#  SECTION:=libs
138
-#  CATEGORY:=Libraries
139
-#  VARIANT:=dbus
140
-#  DEPENDS:=+dbus +libavahi
141
-#  TITLE+= (D-Bus support)
142
-#endef
143
-
144
-#define Package/libavahi-dbus-support/description
145
-#$(call Package/libavahi/description)
146
-# .
147
-# The libavahi-dbus-support package enables
148
-# D-Bus support in avahi, needed to support
149
-# the libavahi-client library and avahi-utils.
150
-# Selecting this package modifies the build configuration
151
-# so that avahi packages are built with support for D-BUS enabled;
152
-# it does not generate a separate binary of its own.
153
-# It also automatically adds the D-Bus package to the build.
154
-# libavahi-dbus-support is selected automatically if you select
155
-# libavahi-client or avahi-utils.
156
-#endef
135
+define Package/libavahi-dbus-support
136
+  $(call Package/avahi/Default)
137
+  SECTION:=libs
138
+  CATEGORY:=Libraries
139
+  VARIANT:=dbus
140
+  DEPENDS:=+dbus +libavahi
141
+  TITLE+= (D-Bus support)
142
+endef
143
+
144
+define Package/libavahi-dbus-support/description
145
+$(call Package/libavahi/description)
146
+ .
147
+ The libavahi-dbus-support package enables
148
+ D-Bus support in avahi, needed to support
149
+ the libavahi-client library and avahi-utils.
150
+ Selecting this package modifies the build configuration
151
+ so that avahi packages are built with support for D-BUS enabled;
152
+ it does not generate a separate binary of its own.
153
+ It also automatically adds the D-Bus package to the build.
154
+ libavahi-dbus-support is selected automatically if you select
155
+ libavahi-client or avahi-utils.
156
+endef
157 157
 
158 158
 define Package/libavahi-client
159 159
   $(call Package/avahi/Default)
@@ -251,10 +251,10 @@ define Build/InstallDev
251 251
 	$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* $(1)/usr/lib/pkgconfig/
252 252
 endef
253 253
 
254
-#define Package/libavahi-dbus-support/install
255
-#	$(INSTALL_DIR) $(1)/etc/dbus-1/system.d
256
-#	$(CP) $(PKG_INSTALL_DIR)/etc/dbus-1/system.d/* $(1)/etc/dbus-1/system.d
257
-#endef
254
+define Package/libavahi-dbus-support/install
255
+	$(INSTALL_DIR) $(1)/etc/dbus-1/system.d
256
+	$(CP) $(PKG_INSTALL_DIR)/etc/dbus-1/system.d/* $(1)/etc/dbus-1/system.d
257
+endef
258 258
 
259 259
 define Package/libavahi/install
260 260
 	# The next line removes the ".build" file from the "other" build.
@@ -306,7 +306,7 @@ endef
306 306
 
307 307
 $(eval $(call BuildPackage,libavahi-client))
308 308
 $(eval $(call BuildPackage,avahi-utils))
309
-#$(eval $(call BuildPackage,libavahi-dbus-support))
309
+$(eval $(call BuildPackage,libavahi-dbus-support))
310 310
 $(eval $(call BuildPackage,libavahi))
311 311
 $(eval $(call BuildPackage,avahi-autoipd))
312 312
 $(eval $(call BuildPackage,avahi-daemon))