Bläddra i källkod

openconnect: separate out vpnc-scripts

Signed-off-by: Daniel Gimpelevich <daniel@gimpelevich.san-francisco.ca.us>
Daniel Gimpelevich 10 år sedan
förälder
incheckning
a904a173ed
3 ändrade filer med 39 tillägg och 3 borttagningar
  1. 2
    3
      net/openconnect/Makefile
  2. 37
    0
      net/vpnc-scripts/Makefile
  3. 0
    0
      net/vpnc-scripts/files/vpnc-script

+ 2
- 3
net/openconnect/Makefile Visa fil

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2006 OpenWrt.org
2
+# Copyright (C) 2006-2015 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
@@ -29,7 +29,7 @@ endef
29 29
 define Package/openconnect
30 30
   SECTION:=net
31 31
   CATEGORY:=Network
32
-  DEPENDS:=+libxml2 +kmod-tun +resolveip +OPENCONNECT_OPENSSL:libopenssl +OPENCONNECT_GNUTLS:libgnutls +OPENCONNECT_STOKEN:libstoken
32
+  DEPENDS:=+libxml2 +kmod-tun +resolveip +vpnc-scripts +OPENCONNECT_OPENSSL:libopenssl +OPENCONNECT_GNUTLS:libgnutls +OPENCONNECT_STOKEN:libstoken
33 33
   TITLE:=OpenConnect VPN client (Cisco AnyConnect compatible)
34 34
   MAINTAINER:=Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com>
35 35
   URL:=http://www.infradead.org/openconnect/
@@ -65,7 +65,6 @@ define Package/openconnect/install
65 65
 	$(INSTALL_DIR) $(1)/etc/openconnect/
66 66
 	$(INSTALL_DIR) $(1)/lib/netifd/proto
67 67
 	$(INSTALL_BIN) ./files/openconnect.sh $(1)/lib/netifd/proto/
68
-	$(INSTALL_BIN) ./files/vpnc-script $(1)/lib/netifd/
69 68
 	$(INSTALL_DIR) $(1)/usr/sbin
70 69
 	$(INSTALL_BIN) $(PKG_BUILD_DIR)/openconnect $(1)/usr/sbin/
71 70
 	$(INSTALL_BIN) ./files/openconnect-wrapper $(1)/usr/sbin/

+ 37
- 0
net/vpnc-scripts/Makefile Visa fil

@@ -0,0 +1,37 @@
1
+#
2
+# Copyright (C) 2006-2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=vpnc-scripts
11
+PKG_VERSION:=20150116
12
+PKG_RELEASE:=1
13
+
14
+include $(INCLUDE_DIR)/package.mk
15
+
16
+define Package/vpnc-scripts
17
+  SECTION:=net
18
+  CATEGORY:=Network
19
+  TITLE:=VPN configuration script for vpnc and OpenConnect
20
+  MAINTAINER:=Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com>
21
+  SUBMENU:=VPN
22
+endef
23
+
24
+define Package/vpnc-scripts/description
25
+	This package contains the vpnc-script which is used by vpnc
26
+	and OpenConnect to configure the tunnel interface.
27
+endef
28
+
29
+define Build/Compile
30
+endef
31
+
32
+define Package/vpnc-scripts/install
33
+	$(INSTALL_DIR) $(1)/lib/netifd
34
+	$(INSTALL_BIN) ./files/vpnc-script $(1)/lib/netifd/
35
+endef
36
+
37
+$(eval $(call BuildPackage,vpnc-scripts))

net/openconnect/files/vpnc-script → net/vpnc-scripts/files/vpnc-script Visa fil