Procházet zdrojové kódy

python-six: new package

From the README:

Six is a Python 2 and 3 compatibility library.  It provides utility functions
for smoothing over the differences between the Python versions with the goal of
writing Python code that is compatible on both Python versions.  See the
documentation for more information on what is provided.

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Jeffery To před 9 roky
rodič
revize
a9af921700
1 změnil soubory, kde provedl 46 přidání a 0 odebrání
  1. 46
    0
      lang/python-six/Makefile

+ 46
- 0
lang/python-six/Makefile Zobrazit soubor

@@ -0,0 +1,46 @@
1
+#
2
+# Copyright (C) 2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=six
11
+PKG_VERSION:=1.10.0
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:=https://pypi.python.org/packages/source/s/six
16
+PKG_MD5SUM:=34eed507548117b2ab523ab14b2f8b55
17
+
18
+PKG_LICENSE:=MIT
19
+PKG_LICENSE_FILES:=LICENSE
20
+PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
21
+
22
+include $(INCLUDE_DIR)/package.mk
23
+$(call include_mk, python-package.mk)
24
+
25
+define Package/python-six
26
+	SECTION:=lang
27
+	CATEGORY:=Languages
28
+	SUBMENU:=Python
29
+	TITLE:=python-six
30
+	URL:=https://pypi.python.org/pypi/six
31
+	DEPENDS:=+python-light
32
+endef
33
+
34
+define Package/python-pyasn1/description
35
+Six is a Python 2 and 3 compatibility library.  It provides utility functions
36
+for smoothing over the differences between the Python versions with the goal of
37
+writing Python code that is compatible on both Python versions.  See the
38
+documentation for more information on what is provided.
39
+endef
40
+
41
+define Build/Compile
42
+	$(call Build/Compile/PyMod,,install --prefix=/usr --root=$(PKG_INSTALL_DIR))
43
+endef
44
+
45
+$(eval $(call PyPackage,python-six))
46
+$(eval $(call BuildPackage,python-six))