Parcourir la source

python: remove readline.so for now

Some symbols are not found (tgetnum and BC).
Looks like the termcap lib, which should be in libncurses(w)
but maybe some build param would be required.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Alexandru Ardelean il y a 10 ans
Parent
révision
a9ba2161bd
1 fichiers modifiés avec 2 ajouts et 1 suppressions
  1. 2
    1
      lang/python/Makefile

+ 2
- 1
lang/python/Makefile Voir le fichier

@@ -64,7 +64,7 @@ endef
64 64
 
65 65
 define Package/python
66 66
 $(call Package/python/Default)
67
-  DEPENDS:=+python-base +libncursesw +libbz2 +libgdbm +libreadline +libsqlite3 +libexpat +libdb47
67
+  DEPENDS:=+python-base +libncursesw +libbz2 +libgdbm +libsqlite3 +libexpat +libdb47
68 68
 endef
69 69
 
70 70
 define Package/python/description
@@ -159,6 +159,7 @@ define PyPackage/python/filespec
159 159
 -|/usr/lib/python$(PYTHON_VERSION)/webbrowser.py
160 160
 -|/usr/lib/python$(PYTHON_VERSION)/*/test
161 161
 -|/usr/lib/python$(PYTHON_VERSION)/*/tests
162
+-|/usr/lib/python$(PYTHON_VERSION)/lib-dynload/readline.so
162 163
 endef
163 164
 
164 165
 define PyPackage/python-base/install