Browse Source

sane-backends: select all backends when CONFIG_ALL

sane-xxx backend packages are hidden packages with custom
config and CONFIG_ALL does not select them alone. Now
sane-backends depends on +ALL:sane-backends-all.

No existing ipk is affected as the changed package/sane-backends
does not exist as an ipk.

030-musl.patch was updated to be submitted upstream. However,
the added preprocessor #if are always true for OpenWRT and will
not change the resulting code.

Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
Luiz Angelo Daros de Luca 9 years ago
parent
commit
aa48cd404a
2 changed files with 19 additions and 6 deletions
  1. 1
    0
      utils/sane-backends/Makefile
  2. 18
    6
      utils/sane-backends/patches/030-musl.patch

+ 1
- 0
utils/sane-backends/Makefile View File

@@ -41,6 +41,7 @@ $(call Package/sane-backends/Default)
41 41
   SECTION:=utils
42 42
   CATEGORY:=Utilities
43 43
   TITLE+= (drivers)
44
+  DEPENDS:=+ALL:sane-backends-all
44 45
 endef
45 46
 
46 47
 define Package/sane-backends/description

+ 18
- 6
utils/sane-backends/patches/030-musl.patch View File

@@ -1,61 +1,73 @@
1 1
 --- a/include/sane/sanei_udp.h
2 2
 +++ b/include/sane/sanei_udp.h
3
-@@ -27,6 +27,7 @@
3
+@@ -27,6 +27,9 @@
4 4
  #include <netinet/in.h>
5 5
  #include <netdb.h>
6 6
  #endif
7
++#ifdef HAVE_SYS_TYPES_H
7 8
 +#include <sys/types.h>
9
++#endif
8 10
  
9 11
  extern SANE_Status sanei_udp_open(const char *host, int port, int *fdp);
10 12
  extern SANE_Status sanei_udp_open_broadcast(int *fdp);
11 13
 --- a/backend/kvs20xx_cmd.h
12 14
 +++ b/backend/kvs20xx_cmd.h
13
-@@ -9,6 +9,8 @@
15
+@@ -9,6 +9,10 @@
14 16
     Panasonic KV-S20xx USB-SCSI scanners.
15 17
  */
16 18
  
19
++#ifdef HAVE_SYS_TYPES_H
17 20
 +#include <sys/types.h>
21
++#endif
18 22
 +
19 23
  #define COMMAND_BLOCK	1
20 24
  #define DATA_BLOCK	2
21 25
  #define RESPONSE_BLOCK	3
22 26
 --- a/backend/kvs40xx.h
23 27
 +++ b/backend/kvs40xx.h
24
-@@ -10,6 +10,7 @@
28
+@@ -10,6 +10,9 @@
25 29
  
26 30
  #include "../include/sane/config.h"
27 31
  #include <semaphore.h>
32
++#ifdef HAVE_SYS_TYPES_H
28 33
 +#include <sys/types.h>
34
++#endif
29 35
  
30 36
  #undef  BACKEND_NAME
31 37
  #define BACKEND_NAME kvs40xx
32 38
 --- a/backend/hp5400.c
33 39
 +++ b/backend/hp5400.c
34
-@@ -67,6 +67,7 @@
40
+@@ -67,6 +67,9 @@
35 41
  #include <stdlib.h>		/* malloc, free */
36 42
  #include <string.h>		/* memcpy */
37 43
  #include <stdio.h>
44
++#ifdef HAVE_SYS_TYPES_H
38 45
 +#include <sys/types.h>
46
++#endif
39 47
  
40 48
  
41 49
  #define HP5400_CONFIG_FILE "hp5400.conf"
42 50
 --- a/backend/hp5590.c
43 51
 +++ b/backend/hp5590.c
44
-@@ -48,6 +48,7 @@
52
+@@ -48,6 +48,9 @@
45 53
  #include <stdio.h>
46 54
  #include <string.h>
47 55
  #include <unistd.h>
56
++#ifdef HAVE_SYS_TYPES_H
48 57
 +#include <sys/types.h>
58
++#endif
49 59
  
50 60
  #include "../include/sane/sane.h"
51 61
  #define BACKEND_NAME hp5590
52 62
 --- a/backend/epsonds-io.c
53 63
 +++ b/backend/epsonds-io.c
54
-@@ -16,6 +16,7 @@
64
+@@ -16,6 +16,9 @@
55 65
  #include "sane/config.h"
56 66
  #include <ctype.h>
57 67
  #include <unistd.h>     /* sleep */
68
++#ifdef HAVE_SYS_TYPES_H
58 69
 +#include <sys/types.h>
70
++#endif
59 71
  
60 72
  #include "epsonds.h"
61 73
  #include "epsonds-io.h"