|
@@ -0,0 +1,14 @@
|
|
1
|
+diff --git a/setup.py b/setup.py
|
|
2
|
+index cbdeaf3..5154412 100644
|
|
3
|
+--- a/setup.py
|
|
4
|
++++ b/setup.py
|
|
5
|
+@@ -480,7 +480,8 @@ class PyBuildExt(build_ext):
|
|
6
|
+ add_dir_to_list(dir_list, directory)
|
|
7
|
+
|
|
8
|
+ if os.path.normpath(sys.prefix) != '/usr' \
|
|
9
|
+- and not sysconfig.get_config_var('PYTHONFRAMEWORK'):
|
|
10
|
++ and not sysconfig.get_config_var('PYTHONFRAMEWORK') \
|
|
11
|
++ and not cross_compiling:
|
|
12
|
+ # OSX note: Don't add LIBDIR and INCLUDEDIR to building a framework
|
|
13
|
+ # (PYTHONFRAMEWORK is set) to avoid # linking problems when
|
|
14
|
+ # building a framework with different architectures than
|