Browse Source

privoxy: modified init scripts

remove "killall" from initscript because it kills itself #867

Signed-off-by: Christian Schoenebeck <christian.schoenebeck@gmail.com>
Christian Schoenebeck 10 years ago
parent
commit
abdd1593f8
2 changed files with 3 additions and 3 deletions
  1. 1
    1
      net/privoxy/Makefile
  2. 2
    2
      net/privoxy/files/privoxy.init

+ 1
- 1
net/privoxy/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=privoxy
11 11
 PKG_VERSION:=3.0.23
12
-PKG_RELEASE:=1
12
+PKG_RELEASE:=2
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-stable-src.tar.gz
15 15
 PKG_SOURCE_URL:=@SF/ijbswa

+ 2
- 2
net/privoxy/files/privoxy.init View File

@@ -108,11 +108,11 @@ stop() {
108 108
 	local _PID=$(cat $PIDFILE 2>/dev/null)
109 109
 	kill -15 $_PID 2>/dev/null
110 110
 	sleep 1			# give time to shutdown
111
-	local _tmp=$(pgrep privoxy)
111
+	local _tmp=$(pgrep privoxy | tr "\n" " ")
112 112
 	if [ -z "$_tmp" ]; then
113 113
 		logger -p daemon.notice -t "privoxy[$_PID]" "Shutdown successfully"
114 114
 	else
115
-		killall -9 privoxy
115
+		kill -9 $_tmp	# Normally never come here
116 116
 		logger -p daemon.warn -t "privoxy[-----]" "Shutdown forced by KILL"
117 117
 	fi
118 118
 	return 0