Browse Source

gstreamer1: Update to 1.4.5, refresh patches

Signed-off-by: Ted Hess <thess@kitschensync.net>
Ted Hess 10 years ago
parent
commit
ac2d4a6cbe

+ 4
- 4
multimedia/gstreamer1/Makefile View File

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2008-2014 OpenWrt.org
2
+# Copyright (C) 2008-2015 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
@@ -8,8 +8,8 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=gstreamer1
11
-PKG_VERSION:=1.4.4
12
-PKG_RELEASE:=2
11
+PKG_VERSION:=1.4.5
12
+PKG_RELEASE:=1
13 13
 
14 14
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
15 15
 
@@ -19,7 +19,7 @@ PKG_LICENSE_FILES:=COPYING
19 19
 PKG_BUILD_DIR:=$(BUILD_DIR)/gstreamer-$(PKG_VERSION)
20 20
 PKG_SOURCE:=gstreamer-$(PKG_VERSION).tar.xz
21 21
 PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gstreamer/
22
-PKG_MD5SUM:=98f4a6d45a28dd195144baef0244ba38
22
+PKG_MD5SUM:=88a9289c64a4950ebb4f544980234289
23 23
 
24 24
 PKG_FIXUP:=autoreconf
25 25
 PKG_REMOVE_FILES:=autogen.sh aclocal.m4

+ 7
- 9
multimedia/gstreamer1/patches/001-no_docs.patch View File

@@ -1,7 +1,6 @@
1
-diff -u --recursive gstreamer-1.0.7-vanilla/Makefile.am gstreamer-1.0.7/Makefile.am
2
---- gstreamer-1.0.7-vanilla/Makefile.am	2013-06-01 18:47:44.498057069 -0500
3
-+++ gstreamer-1.0.7/Makefile.am	2013-06-01 19:01:41.634143861 -0500
4
-@@ -8,7 +8,6 @@
1
+--- a/Makefile.am
2
++++ b/Makefile.am
3
+@@ -8,7 +8,6 @@ aclocal_DATA = gst-element-check-@GST_AP
5 4
  
6 5
  SUBDIRS = pkgconfig \
7 6
  	gst libs plugins tests \
@@ -9,7 +8,7 @@ diff -u --recursive gstreamer-1.0.7-vanilla/Makefile.am gstreamer-1.0.7/Makefile
9 8
  	po \
10 9
  	m4 \
11 10
  	common
12
-@@ -20,7 +19,6 @@
11
+@@ -20,7 +19,6 @@ endif
13 12
  # These are all the possible subdirs
14 13
  DIST_SUBDIRS = pkgconfig \
15 14
  	gst libs plugins tools tests \
@@ -17,10 +16,9 @@ diff -u --recursive gstreamer-1.0.7-vanilla/Makefile.am gstreamer-1.0.7/Makefile
17 16
  	po \
18 17
  	m4 \
19 18
  	common
20
-diff -u --recursive gstreamer-1.0.7-vanilla/Makefile.in gstreamer-1.0.7/Makefile.in
21
---- gstreamer-1.0.7-vanilla/Makefile.in	2013-06-01 18:47:44.533056863 -0500
22
-+++ gstreamer-1.0.7/Makefile.in	2013-06-01 19:02:04.529246907 -0500
23
-@@ -508,13 +508,12 @@
19
+--- a/Makefile.in
20
++++ b/Makefile.in
21
+@@ -554,13 +554,12 @@ top_srcdir = @top_srcdir@
24 22
  DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --enable-docbook
25 23
  aclocaldir = $(datadir)/aclocal
26 24
  aclocal_DATA = gst-element-check-@GST_API_VERSION@.m4

+ 7
- 9
multimedia/gstreamer1/patches/002-no_tests.patch View File

@@ -1,7 +1,6 @@
1
-diff -u --recursive gstreamer-1.0.7-vanilla/Makefile.am gstreamer-1.0.7/Makefile.am
2
---- gstreamer-1.0.7-vanilla/Makefile.am	2013-06-01 19:22:31.546496381 -0500
3
-+++ gstreamer-1.0.7/Makefile.am	2013-06-01 19:20:38.141070908 -0500
4
-@@ -7,7 +7,7 @@
1
+--- a/Makefile.am
2
++++ b/Makefile.am
3
+@@ -7,7 +7,7 @@ aclocaldir = $(datadir)/aclocal
5 4
  aclocal_DATA = gst-element-check-@GST_API_VERSION@.m4
6 5
  
7 6
  SUBDIRS = pkgconfig \
@@ -10,7 +9,7 @@ diff -u --recursive gstreamer-1.0.7-vanilla/Makefile.am gstreamer-1.0.7/Makefile
10 9
  	po \
11 10
  	m4 \
12 11
  	common
13
-@@ -18,7 +18,7 @@
12
+@@ -18,7 +18,7 @@ endif
14 13
  
15 14
  # These are all the possible subdirs
16 15
  DIST_SUBDIRS = pkgconfig \
@@ -19,10 +18,9 @@ diff -u --recursive gstreamer-1.0.7-vanilla/Makefile.am gstreamer-1.0.7/Makefile
19 18
  	po \
20 19
  	m4 \
21 20
  	common
22
-diff -u --recursive gstreamer-1.0.7-vanilla/Makefile.in gstreamer-1.0.7/Makefile.in
23
---- gstreamer-1.0.7-vanilla/Makefile.in	2013-06-01 19:22:31.547496342 -0500
24
-+++ gstreamer-1.0.7/Makefile.in	2013-06-01 19:20:48.948632307 -0500
25
-@@ -508,12 +508,12 @@
21
+--- a/Makefile.in
22
++++ b/Makefile.in
23
+@@ -554,12 +554,12 @@ top_srcdir = @top_srcdir@
26 24
  DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --enable-docbook
27 25
  aclocaldir = $(datadir)/aclocal
28 26
  aclocal_DATA = gst-element-check-@GST_API_VERSION@.m4

+ 10
- 13
multimedia/gstreamer1/patches/003-no_translations.patch View File

@@ -1,7 +1,6 @@
1
-diff -u --recursive gstreamer-1.0.7-vanilla/configure.ac gstreamer-1.0.7/configure.ac
2
---- gstreamer-1.0.7-vanilla/configure.ac	2013-06-01 18:47:44.506057110 -0500
3
-+++ gstreamer-1.0.7/configure.ac	2013-06-01 19:24:05.035756124 -0500
4
-@@ -769,7 +769,6 @@
1
+--- a/configure.ac
2
++++ b/configure.ac
3
+@@ -780,7 +780,6 @@ libs/gst/helpers/Makefile
5 4
  libs/gst/net/Makefile
6 5
  plugins/Makefile
7 6
  plugins/elements/Makefile
@@ -9,10 +8,9 @@ diff -u --recursive gstreamer-1.0.7-vanilla/configure.ac gstreamer-1.0.7/configu
9 8
  tests/Makefile
10 9
  tests/benchmarks/Makefile
11 10
  tests/check/Makefile
12
-diff -u --recursive gstreamer-1.0.7-vanilla/Makefile.am gstreamer-1.0.7/Makefile.am
13
---- gstreamer-1.0.7-vanilla/Makefile.am	2013-06-01 19:23:08.361020919 -0500
14
-+++ gstreamer-1.0.7/Makefile.am	2013-06-01 19:24:15.036357308 -0500
15
-@@ -8,7 +8,6 @@
11
+--- a/Makefile.am
12
++++ b/Makefile.am
13
+@@ -8,7 +8,6 @@ aclocal_DATA = gst-element-check-@GST_AP
16 14
  
17 15
  SUBDIRS = pkgconfig \
18 16
  	gst libs plugins \
@@ -20,7 +18,7 @@ diff -u --recursive gstreamer-1.0.7-vanilla/Makefile.am gstreamer-1.0.7/Makefile
20 18
  	m4 \
21 19
  	common
22 20
  
23
-@@ -19,7 +18,6 @@
21
+@@ -19,7 +18,6 @@ endif
24 22
  # These are all the possible subdirs
25 23
  DIST_SUBDIRS = pkgconfig \
26 24
  	gst libs plugins tools \
@@ -28,10 +26,9 @@ diff -u --recursive gstreamer-1.0.7-vanilla/Makefile.am gstreamer-1.0.7/Makefile
28 26
  	m4 \
29 27
  	common
30 28
  
31
-diff -u --recursive gstreamer-1.0.7-vanilla/Makefile.in gstreamer-1.0.7/Makefile.in
32
---- gstreamer-1.0.7-vanilla/Makefile.in	2013-06-01 19:23:08.362020867 -0500
33
-+++ gstreamer-1.0.7/Makefile.in	2013-06-01 19:24:27.907844191 -0500
34
-@@ -508,13 +508,12 @@
29
+--- a/Makefile.in
30
++++ b/Makefile.in
31
+@@ -554,13 +554,12 @@ top_srcdir = @top_srcdir@
35 32
  DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --enable-docbook
36 33
  aclocaldir = $(datadir)/aclocal
37 34
  aclocal_DATA = gst-element-check-@GST_API_VERSION@.m4