|
@@ -0,0 +1,46 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2009 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=intltool
|
|
11
|
+PKG_LIBVER:=0.40
|
|
12
|
+PKG_VERSION:=$(PKG_LIBVER).6
|
|
13
|
+PKG_RELEASE:=1
|
|
14
|
+
|
|
15
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
|
16
|
+PKG_SOURCE_URL:=@GNOME/intltool/$(PKG_LIBVER)
|
|
17
|
+PKG_MD5SUM:=69bc0353323112f42ad4f9cf351bc3e5
|
|
18
|
+
|
|
19
|
+PKG_HOST_ONLY:=1
|
|
20
|
+
|
|
21
|
+include $(INCLUDE_DIR)/host-build.mk
|
|
22
|
+include $(INCLUDE_DIR)/package.mk
|
|
23
|
+
|
|
24
|
+define Package/intltool
|
|
25
|
+ SECTION:=libs
|
|
26
|
+ CATEGORY:=Libraries
|
|
27
|
+ TITLE:=set of tools to centralize translation using GNU gettext
|
|
28
|
+ URL:=http://www.freedesktop.org/wiki/Software/intltool
|
|
29
|
+ BUILDONLY:=1
|
|
30
|
+endef
|
|
31
|
+
|
|
32
|
+define Package/intltool/description
|
|
33
|
+ intltool is a set of tools to centralize translation of many different
|
|
34
|
+ file formats using GNU gettext-compatible PO files.
|
|
35
|
+endef
|
|
36
|
+
|
|
37
|
+define Require/perl-xml-parser
|
|
38
|
+ perl -e 'use XML::Parser;'
|
|
39
|
+endef
|
|
40
|
+
|
|
41
|
+$(eval $(call Require,perl-xml-parser, \
|
|
42
|
+ Please install Perl XML::Parser \
|
|
43
|
+))
|
|
44
|
+
|
|
45
|
+$(eval $(call BuildPackage,intltool))
|
|
46
|
+$(eval $(call HostBuild))
|