Quellcode durchsuchen

python3: add python3-package-lzma.mk

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Alexandru Ardelean vor 9 Jahren
Ursprung
Commit
aceacb4de0
1 geänderte Dateien mit 17 neuen und 0 gelöschten Zeilen
  1. 17
    0
      lang/python3/files/python3-package-lzma.mk

+ 17
- 0
lang/python3/files/python3-package-lzma.mk Datei anzeigen

@@ -0,0 +1,17 @@
1
+#
2
+# Copyright (C) 2006-2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+define Package/python3-lzma
9
+$(call Package/python3/Default)
10
+  TITLE:=Python $(PYTHON3_VERSION) lzma module
11
+  DEPENDS:=+python3-light +liblzma
12
+endef
13
+
14
+$(eval $(call Py3BasePackage,python3-lzma, \
15
+	/usr/lib/python$(PYTHON3_VERSION)/lzma.py \
16
+	/usr/lib/python$(PYTHON3_VERSION)/lib-dynload/_lzma.$(PYTHON3_SO_SUFFIX) \
17
+))