Преглед на файлове

protobuf-c: use generic autoreconf fixup

Invoke the generic autoreconf fixup instead of calling the shipped autogen.sh.

This ensures that proper variants of libtoolize, autoconf, automake etc. are
used, otherwise it is not possible to rebuild protobuf-c in the SDK env.

The change requires backport to BB as it currently blocks the rebuild of ocerv.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Jo-Philipp Wich преди 10 години
родител
ревизия
ad1d97d8e6
променени са 1 файла, в които са добавени 1 реда и са изтрити 5 реда
  1. 1
    5
      libs/protobuf-c/Makefile

+ 1
- 5
libs/protobuf-c/Makefile Целия файл

@@ -18,6 +18,7 @@ PKG_SOURCE_PROTO:=git
18 18
 PKG_SOURCE_VERSION:=$(PKG_VERSION)
19 19
 
20 20
 PKG_INSTALL:=1
21
+PKG_FIXUP:=autoreconf
21 22
 
22 23
 PKG_LICENSE:=BSD-2c
23 24
 
@@ -44,11 +45,6 @@ CONFIGURE_ARGS += \
44 45
 	--enable-static \
45 46
 	--disable-protoc
46 47
 
47
-define Build/Configure
48
-	cd $(PKG_BUILD_DIR) && ./autogen.sh
49
-	$(call Build/Configure/Default)
50
-endef
51
-
52 48
 define Build/InstallDev
53 49
 	$(INSTALL_DIR) $(1)/usr/include/
54 50
 	$(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/