瀏覽代碼

ffmpeg: add libopus support

Signed-off-by: Ian Leonard <antonlacon@gmail.com>
Ian Leonard 10 年之前
父節點
當前提交
ad20ef1147
共有 2 個文件被更改,包括 13 次插入2 次删除
  1. 4
    0
      multimedia/ffmpeg/Config.in
  2. 9
    2
      multimedia/ffmpeg/Makefile

+ 4
- 0
multimedia/ffmpeg/Config.in 查看文件

@@ -60,6 +60,7 @@ config FFMPEG_CUSTOM_AUDIO_DEC_SUPPORT
60 60
 	select FFMPEG_CUSTOM_DECODER_ape
61 61
 	select FFMPEG_CUSTOM_DECODER_atrac3
62 62
 	select FFMPEG_CUSTOM_DECODER_flac
63
+	select FFMPEG_CUSTOM_SELECT_libopus
63 64
 	select FFMPEG_CUSTOM_DECODER_mp2
64 65
 	select FFMPEG_CUSTOM_DECODER_mp3
65 66
 	select FFMPEG_CUSTOM_DECODER_mpc7
@@ -108,6 +109,9 @@ config FFMPEG_CUSTOM_AUDIO_DEC_SUPPORT
108 109
 
109 110
 comment "External Libraries ---"
110 111
 
112
+config FFMPEG_CUSTOM_SELECT_libopus
113
+	bool "Opus"
114
+
111 115
 config FFMPEG_CUSTOM_SELECT_speex
112 116
 	bool "Speex"
113 117
 

+ 9
- 2
multimedia/ffmpeg/Makefile 查看文件

@@ -289,7 +289,7 @@ endef
289 289
 define Package/libffmpeg-custom
290 290
 $(call Package/libffmpeg/Default)
291 291
  TITLE+= (custom)
292
- DEPENDS+= @DEVEL +libspeex
292
+ DEPENDS+= @DEVEL +libopus +libspeex
293 293
  VARIANT:=custom
294 294
  MENU:=1
295 295
 endef
@@ -308,7 +308,7 @@ endef
308 308
 define Package/libffmpeg-audio-dec
309 309
 $(call Package/libffmpeg/Default)
310 310
  TITLE+= (audio)
311
- DEPENDS+= @DEVEL +libspeex
311
+ DEPENDS+= @DEVEL +libopus +libspeex
312 312
  VARIANT:=audio-dec
313 313
 endef
314 314
 
@@ -428,6 +428,12 @@ ifeq ($(CONFIG_FFMPEG_CUSTOM_SELECT_adpcm),y)
428 428
 
429 429
 endif
430 430
 
431
+ifeq ($(CONFIG_FFMPEG_CUSTOM_SELECT_libopus),y)
432
+  FFMPEG_CONFIGURE+= \
433
+	--enable-libopus --enable-decoder=libopus \
434
+
435
+endif
436
+
431 437
 ifeq ($(CONFIG_FFMPEG_CUSTOM_SELECT_speex),y)
432 438
   FFMPEG_CONFIGURE+= \
433 439
 	--enable-libspeex --enable-decoder=libspeex \
@@ -454,6 +460,7 @@ ifeq ($(BUILD_VARIANT),audio-dec)
454 460
 	$(call FFMPEG_ENABLE,demuxer,$(FFMPEG_AUDIO_DEMUXERS)) \
455 461
 	$(call FFMPEG_ENABLE,parser,$(FFMPEG_AUDIO_PARSERS)) \
456 462
 	$(call FFMPEG_ENABLE,protocol,$(FFMPEG_AUDIO_PROTOCOLS)) \
463
+	--enable-libopus --enable-decoder=libopus \
457 464
 	--enable-libspeex --enable-decoder=libspeex \
458 465
 	--disable-decoder=pcm_bluray,pcm_dvd \
459 466