Browse Source

openocd: fix package dependencies

OpenOCD autoselects libftdi1 when it's present, and should explicitly
depend on it, same about libusb-0.1 API which is provided by
libusb-compat.

Signed-off-by: Paul Fertser <fercerpav@gmail.com>
Paul Fertser 10 years ago
parent
commit
ad9ae24a29
1 changed files with 2 additions and 2 deletions
  1. 2
    2
      utils/openocd/Makefile

+ 2
- 2
utils/openocd/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=openocd
11 11
 PKG_VERSION:=v0.8.0-258-gd537cfa
12
-PKG_RELEASE:=1
12
+PKG_RELEASE:=2
13 13
 
14 14
 PKG_SOURCE_PROTO:=git
15 15
 PKG_SOURCE_URL:=git://git.code.sf.net/p/openocd/code
@@ -32,7 +32,7 @@ define Package/openocd
32 32
   CATEGORY:=Utilities
33 33
   TITLE:=OpenOCD Utility
34 34
   URL:=http://openocd.sf.net/
35
-  DEPENDS:=+libusb-1.0 +libftdi +hidapi
35
+  DEPENDS:=+libusb-1.0 +libusb-compat +libftdi1 +hidapi
36 36
 endef
37 37
 
38 38
 define Package/openocd/description