Browse Source

ffmpeg: libffmpeg-audio-dec and -custom use integrated opus decoder

For libffmpeg-audio-dec:

Remove @DEVEL flag from libffmpeg-audio-dec. Reasoning for this is
that choosing this package does not rquire any further action by the
builder in what codecs or formats should be built in.
libffmpeg-custom, the other libffmpeg to require @DEVEL, does need
further interaction.

Add @BUILD_PATENTED as at least one of the audio codecs is likely
patent protected.

Add ffmpeg's native Opus decoder to libffmpeg-audio-dec

Remove libopus dependency to libffmpeg-audio-dec as libopus provides
decode and encode support for Opus audio. Since FFmpeg can decode
Opus audio on its own, and libffmpeg-audio-dec is intended for audio
decoding, libopus is no longer required for Opus audio support.

For libffmpeg-custom:

Add in options for ffmpeg's integrated Opus decoder

Signed-off-by: Ian Leonard <antonlacon@gmail.com>
Ian Leonard 9 years ago
parent
commit
ae13b1441d
2 changed files with 14 additions and 6 deletions
  1. 9
    2
      multimedia/ffmpeg/Config.in
  2. 5
    4
      multimedia/ffmpeg/Makefile

+ 9
- 2
multimedia/ffmpeg/Config.in View File

@@ -60,11 +60,11 @@ config FFMPEG_CUSTOM_AUDIO_DEC_SUPPORT
60 60
 	select FFMPEG_CUSTOM_DECODER_ape
61 61
 	select FFMPEG_CUSTOM_DECODER_atrac3
62 62
 	select FFMPEG_CUSTOM_DECODER_flac
63
-	select FFMPEG_CUSTOM_SELECT_libopus
64 63
 	select FFMPEG_CUSTOM_DECODER_mp2
65 64
 	select FFMPEG_CUSTOM_DECODER_mp3
66 65
 	select FFMPEG_CUSTOM_DECODER_mpc7
67 66
 	select FFMPEG_CUSTOM_DECODER_mpc8
67
+	select FFMPEG_CUSTOM_DECODER_opus
68 68
 	select FFMPEG_CUSTOM_DECODER_pcm_s16be
69 69
 	select FFMPEG_CUSTOM_DECODER_pcm_s16le
70 70
 	select FFMPEG_CUSTOM_SELECT_speex
@@ -98,9 +98,10 @@ config FFMPEG_CUSTOM_AUDIO_DEC_SUPPORT
98 98
 	select FFMPEG_CUSTOM_DEMUXER_wv
99 99
 	select FFMPEG_CUSTOM_PARSER_aac
100 100
 	select FFMPEG_CUSTOM_PARSER_aac_latm
101
-	select FFMPEG_CUSTOM_PARSER_flac
102 101
 	select FFMPEG_CUSTOM_PARSER_ac3
102
+	select FFMPEG_CUSTOM_PARSER_flac
103 103
 	select FFMPEG_CUSTOM_PARSER_mpegaudio
104
+	select FFMPEG_CUSTOM_PARSER_opus
104 105
 	select FFMPEG_CUSTOM_PROTOCOL_file
105 106
 	select FFMPEG_CUSTOM_PROTOCOL_http
106 107
 	select FFMPEG_CUSTOM_PROTOCOL_rtp
@@ -229,6 +230,9 @@ config FFMPEG_CUSTOM_DECODER_mpc8
229 230
 	bool "Musepack 8"
230 231
 	select FFMPEG_CUSTOM_DEMUXER_mpc8
231 232
 
233
+config FFMPEG_CUSTOM_DECODER_opus
234
+	bool "Opus"
235
+
232 236
 config FFMPEG_CUSTOM_DECODER_pcm_s16be
233 237
 	bool "PCM signed 16-bit big-endian"
234 238
 
@@ -398,6 +402,9 @@ config FFMPEG_CUSTOM_PARSER_mpegvideo
398 402
 config FFMPEG_CUSTOM_PARSER_mpeg4video
399 403
 	bool "MPEG-4 Video"
400 404
 
405
+config FFMPEG_CUSTOM_PARSER_opus
406
+	bool "Opus"
407
+
401 408
 comment "Protocols ---"
402 409
 
403 410
 config FFMPEG_CUSTOM_PROTOCOL_file

+ 5
- 4
multimedia/ffmpeg/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=ffmpeg
11 11
 PKG_VERSION:=2.6.3
12
-PKG_RELEASE:=1
12
+PKG_RELEASE:=2
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
15 15
 PKG_SOURCE_URL:=http://ffmpeg.org/releases/
@@ -162,6 +162,7 @@ FFMPEG_AUDIO_DECODERS:= \
162 162
 	mp3* \
163 163
 	mpc7 \
164 164
 	mpc8 \
165
+	opus \
165 166
 	pcm_* \
166 167
 	vorbis \
167 168
 	wavpack \
@@ -197,9 +198,10 @@ FFMPEG_AUDIO_DEMUXERS:= \
197 198
 FFMPEG_AUDIO_PARSERS:= \
198 199
 	aac \
199 200
 	aac_latm \
200
-	flac \
201 201
 	ac3 \
202
+	flac \
202 203
 	mpegaudio \
204
+	opus \
203 205
 
204 206
 FFMPEG_AUDIO_PROTOCOLS:= \
205 207
 	file http icecast rtp tcp udp
@@ -308,7 +310,7 @@ endef
308 310
 define Package/libffmpeg-audio-dec
309 311
 $(call Package/libffmpeg/Default)
310 312
  TITLE+= (audio)
311
- DEPENDS+= @DEVEL +libopus +libspeex
313
+ DEPENDS+= @BUILD_PATENTED +libspeex
312 314
  VARIANT:=audio-dec
313 315
 endef
314 316
 
@@ -462,7 +464,6 @@ ifeq ($(BUILD_VARIANT),audio-dec)
462 464
 	$(call FFMPEG_ENABLE,demuxer,$(FFMPEG_AUDIO_DEMUXERS)) \
463 465
 	$(call FFMPEG_ENABLE,parser,$(FFMPEG_AUDIO_PARSERS)) \
464 466
 	$(call FFMPEG_ENABLE,protocol,$(FFMPEG_AUDIO_PROTOCOLS)) \
465
-	--enable-libopus --enable-decoder=libopus \
466 467
 	--enable-libspeex --enable-decoder=libspeex \
467 468
 	--disable-decoder=pcm_bluray,pcm_dvd \
468 469