|
@@ -0,0 +1,44 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2008-2014 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=patch
|
|
11
|
+PKG_VERSION:=2.7.1
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
15
|
+PKG_SOURCE_URL:=@GNU/patch
|
|
16
|
+PKG_MD5SUM:=95dd8d7e41dcbcecdd5cd88ef915378d
|
|
17
|
+
|
|
18
|
+include $(INCLUDE_DIR)/package.mk
|
|
19
|
+
|
|
20
|
+define Package/patch
|
|
21
|
+ SECTION:=devel
|
|
22
|
+ CATEGORY:=Development
|
|
23
|
+ TITLE:=patch
|
|
24
|
+ URL:=http://www.gnu.org/
|
|
25
|
+ MAINTAINER:=Russell Senior <russell@personaltelco.net>
|
|
26
|
+endef
|
|
27
|
+
|
|
28
|
+define Package/patch/description
|
|
29
|
+ The Patch package contains a program for modifying or creating files
|
|
30
|
+ by applying a "patch" file typically created by the diff program.
|
|
31
|
+endef
|
|
32
|
+
|
|
33
|
+define Build/Compile
|
|
34
|
+ $(MAKE) -C $(PKG_BUILD_DIR) \
|
|
35
|
+ DESTDIR="$(PKG_INSTALL_DIR)" \
|
|
36
|
+ all install
|
|
37
|
+endef
|
|
38
|
+
|
|
39
|
+define Package/patch/install
|
|
40
|
+ $(INSTALL_DIR) $(1)/usr/bin
|
|
41
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/patch $(1)/usr/bin/
|
|
42
|
+endef
|
|
43
|
+
|
|
44
|
+$(eval $(call BuildPackage,patch))
|