Browse Source

python: use command instead of 'ln -sf'

Alexandru Ardelean 10 years ago
parent
commit
b0c21ae7aa
1 changed files with 4 additions and 4 deletions
  1. 4
    4
      lang/python/Makefile

+ 4
- 4
lang/python/Makefile View File

@@ -192,8 +192,8 @@ define Build/InstallDev
192 192
 		$(STAGING_DIR_HOST)/bin/python$(PYTHON_VERSION) \
193 193
 		$(1)/usr/bin/hostpython
194 194
 	(cd $(2)/bin; \
195
-	ln -sf ../../usr/bin/hostpython python$(PYTHON_VERSION); \
196
-	ln -sf python$(PYTHON_VERSION) python)
195
+	$(LN) ../../usr/bin/hostpython python$(PYTHON_VERSION); \
196
+	$(LN) python$(PYTHON_VERSION) python)
197 197
 
198 198
 	$(CP) \
199 199
 		$(STAGING_DIR_HOST)/bin/python$(PYTHON_VERSION)-config \
@@ -201,7 +201,7 @@ define Build/InstallDev
201 201
 	$(SED) 's,^#!.*,#!/usr/bin/env python$(PYTHON_VERSION),g' $(2)/bin/python$(PYTHON_VERSION)-config
202 202
 
203 203
 	(cd $(2)/bin; \
204
-	ln -sf python$(PYTHON_VERSION)-config python-config;)
204
+	$(LN) python$(PYTHON_VERSION)-config python-config;)
205 205
 endef
206 206
 
207 207
 define PyPackage/python-full/filespec
@@ -410,7 +410,7 @@ define PyPackage/python/filespec
410 410
 endef
411 411
 
412 412
 define PyPackage/python/install
413
-	ln -sf python$(PYTHON_VERSION) $(1)/usr/bin/python
413
+	$(LN) python$(PYTHON_VERSION) $(1)/usr/bin/python
414 414
 endef
415 415
 
416 416
 define PyPackage/python-doc/filespec