Browse Source

squid: version bump and dependency fixes

Signed-off-by: Daniel Gimpelevich <daniel@gimpelevich.san-francisco.ca.us>
Daniel Gimpelevich 9 years ago
parent
commit
b127de865b
4 changed files with 22 additions and 12 deletions
  1. 10
    9
      net/squid/Makefile
  2. 1
    1
      net/squid/files/squid.conf
  3. 3
    0
      net/squid/files/squid.config
  4. 8
    2
      net/squid/files/squid.init

+ 10
- 9
net/squid/Makefile View File

@@ -8,7 +8,7 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=squid
11
-PKG_VERSION:=3.5.5
11
+PKG_VERSION:=3.5.6
12 12
 PKG_RELEASE:=1
13 13
 
14 14
 PKG_LICENSE:=GPL-2.0
@@ -16,7 +16,7 @@ PKG_MAINTAINER:=Luka Perkov <luka@openwrt.org>
16 16
 
17 17
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
18 18
 PKG_SOURCE_URL:=http://www.squid-cache.org/Versions/v3/3.5/
19
-PKG_MD5SUM:=9a323a97753143ddd935aed58a0193ae
19
+PKG_MD5SUM:=93e18bd257857e35bb634ddb8a348563
20 20
 
21 21
 PKG_BUILD_PARALLEL:=1
22 22
 PKG_INSTALL:=1
@@ -33,7 +33,7 @@ endef
33 33
 define Package/squid
34 34
   $(call Package/squid/Default)
35 35
   MENU:=1
36
-  DEPENDS:=+libopenssl +libpthread +librt +libltdl +libstdcpp +libgnutls
36
+  DEPENDS:=+libopenssl +libpthread +librt +libltdl +libstdcpp
37 37
   TITLE:=full-featured Web proxy cache
38 38
 endef
39 39
 
@@ -62,12 +62,8 @@ CONFIGURE_ARGS += \
62 62
 	--enable-kill-parent-hack \
63 63
 	--disable-snmp \
64 64
 	--enable-ssl \
65
+	--enable-ssl-crtd \
65 66
 	--enable-cache-digests \
66
-	--enable-auth \
67
-	--enable-auth-basic \
68
-	--enable-auth-ntlm \
69
-	--enable-auth-negotiate \
70
-	--enable-auth-digest \
71 67
 	--enable-linux-netfilter \
72 68
 	--disable-unlinkd \
73 69
 	--enable-x-accelerator-vary \
@@ -77,6 +73,7 @@ CONFIGURE_ARGS += \
77 73
 	--with-pthreads \
78 74
 	--without-expat \
79 75
 	--without-libxml2 \
76
+	--without-gnutls \
80 77
 	--without-nettle \
81 78
 	--with-openssl=$(STAGING_DIR)/usr \
82 79
 	--enable-epoll \
@@ -93,7 +90,8 @@ CONFIGURE_ARGS += \
93 90
 
94 91
 CONFIGURE_VARS += \
95 92
 	ac_cv_header_linux_netfilter_ipv4_h=yes \
96
-	ac_cv_epoll_works=yes
93
+	ac_cv_epoll_works=yes \
94
+	squid_cv_gnu_atomics=no
97 95
 
98 96
 define Build/Compile
99 97
 	+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR)/lib all
@@ -106,6 +104,9 @@ define Package/squid/install
106 104
 	$(INSTALL_DIR) $(1)/usr/sbin
107 105
 	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/squid $(1)/usr/sbin/
108 106
 
107
+	$(INSTALL_DIR) $(1)/usr/lib/squid
108
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/squid/ssl_crtd $(1)/usr/lib/squid
109
+
109 110
 	$(INSTALL_DIR) $(1)/etc/config
110 111
 	$(INSTALL_CONF) ./files/squid.config $(1)/etc/config/squid
111 112
 

+ 1
- 1
net/squid/files/squid.conf View File

@@ -38,7 +38,7 @@ refresh_pattern . 0 20% 4320
38 38
 
39 39
 access_log none
40 40
 cache_log /dev/null
41
-cache_store_log /dev/null
41
+cache_store_log stdio:/dev/null
42 42
 logfile_rotate 0
43 43
 
44 44
 logfile_daemon /dev/null

+ 3
- 0
net/squid/files/squid.config View File

@@ -3,3 +3,6 @@ config squid 'squid'
3 3
 	option http_port '3128'
4 4
 	option coredump_dir '/tmp/squid'
5 5
 	option visible_hostname 'OpenWrt'
6
+	#option http_port_options 'intercept'
7
+	#option ssldb '/tmp/squid/ssldb'
8
+	#option ssldb_options '-M 4MB'

+ 8
- 2
net/squid/files/squid.init View File

@@ -12,13 +12,16 @@ validate_squid_section() {
12 12
 	uci_validate_section squid squid "${1}" \
13 13
 		'config_file:string' \
14 14
 		'http_port:port:3128' \
15
+		'http_port_options:string' \
16
+		'ssldb:string' \
17
+		'ssldb_options:string' \
15 18
 		'coredump_dir:string' \
16 19
 		'visible_hostname:string:OpenWrt' \
17 20
 		'pinger_enable:string:off'
18 21
 }
19 22
 
20 23
 start_service() {
21
-	local config_file http_port coredump_dir visible_hostname pinger_enable
24
+	local config_file http_port http_port_options ssldb ssldb_options coredump_dir visible_hostname pinger_enable
22 25
 
23 26
 	validate_squid_section squid || {
24 27
 		echo "validation failed"
@@ -28,12 +31,15 @@ start_service() {
28 31
 	config_dir=$(dirname $CONFIGFILE)
29 32
 	[ -d $config_dir ] || mkdir -p $config_dir && chown nobody:nogroup $config_dir
30 33
 	[ -d $coredump_dir ] || mkdir -p $coredump_dir && chown nobody:nogroup $coredump_dir
34
+	[ "$ssldb" ] && ( [ -f "$ssldb"/size ] || /usr/lib/squid/ssl_crtd -c -s $ssldb && chown -R nobody:nogroup $ssldb )
31 35
 
32 36
 	cat $config_file > $CONFIGFILE
33
-	echo http_port $http_port >> $CONFIGFILE
37
+	echo http_port $http_port $http_port_options >> $CONFIGFILE
34 38
 	echo coredump_dir $coredump_dir >> $CONFIGFILE
35 39
 	echo visible_hostname $visible_hostname >> $CONFIGFILE
36 40
 	echo pinger_enable $pinger_enable >> $CONFIGFILE
41
+	[ "$ssldb" ] && echo sslcrtd_program /usr/lib/squid/ssl_crtd -s $ssldb $ssldb_options >> $CONFIGFILE
42
+	$PROG -s -f $CONFIGFILE -N -z 2>/dev/null
37 43
 
38 44
 	procd_open_instance
39 45
 	procd_set_param command $PROG -s -f $CONFIGFILE -N