Browse Source

nut: Update to 2.7.3

Updated the package to the latest upstream version.
Removed a patch that was merged upstream.
Bumped copyright notice to 2015.

Signed-off-by: Martin Rowe <martin.p.rowe@gmail.com>
Marty R 9 years ago
parent
commit
b195c1c367
2 changed files with 3 additions and 25 deletions
  1. 3
    3
      net/nut/Makefile
  2. 0
    22
      net/nut/patches/001-fix-missing-libmath-flags.patch

+ 3
- 3
net/nut/Makefile View File

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2006-2014 OpenWrt.org
2
+# Copyright (C) 2006-2015 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=nut
11
-PKG_VERSION:=2.7.2
11
+PKG_VERSION:=2.7.3
12 12
 PKG_RELEASE:=1
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=http://www.networkupstools.org/source/2.7/
16
-PKG_MD5SUM:=c3568b42e058cfc385b46d25140dced4
16
+PKG_MD5SUM:=a1a7f747093663e1f39ab595b63b45e4
17 17
 PKG_MAINTAINER:=Martin Rowe <martin.p.rowe@gmail.com>
18 18
 PKG_LICENSE:=GPL-2.0
19 19
 PKG_LICENSE_FILES:=LICENSE-GPL2

+ 0
- 22
net/nut/patches/001-fix-missing-libmath-flags.patch View File

@@ -1,22 +0,0 @@
1
---- a/drivers/Makefile.am
2
-+++ b/drivers/Makefile.am
3
-@@ -171,7 +171,7 @@ tripplite_usb_SOURCES = tripplite_usb.c
4
- tripplite_usb_LDADD = $(LDADD_DRIVERS) $(LIBUSB_LIBS) -lm
5
- 
6
- bcmxcp_usb_SOURCES = bcmxcp_usb.c bcmxcp.c usb-common.c
7
--bcmxcp_usb_LDADD = $(LDADD_DRIVERS) $(LIBUSB_LIBS)
8
-+bcmxcp_usb_LDADD = $(LDADD_DRIVERS) $(LIBUSB_LIBS) -lm
9
- 
10
- blazer_usb_SOURCES = blazer.c blazer_usb.c libusb.c usb-common.c
11
- blazer_usb_LDADD = $(LDADD_DRIVERS) $(LIBUSB_LIBS) -lm
12
---- a/drivers/Makefile.in
13
-+++ b/drivers/Makefile.in
14
-@@ -785,7 +785,7 @@ usbhid_ups_LDADD = $(LDADD_DRIVERS) $(LI
15
- tripplite_usb_SOURCES = tripplite_usb.c libusb.c usb-common.c
16
- tripplite_usb_LDADD = $(LDADD_DRIVERS) $(LIBUSB_LIBS) -lm
17
- bcmxcp_usb_SOURCES = bcmxcp_usb.c bcmxcp.c usb-common.c
18
--bcmxcp_usb_LDADD = $(LDADD_DRIVERS) $(LIBUSB_LIBS)
19
-+bcmxcp_usb_LDADD = $(LDADD_DRIVERS) $(LIBUSB_LIBS) -lm
20
- blazer_usb_SOURCES = blazer.c blazer_usb.c libusb.c usb-common.c
21
- blazer_usb_LDADD = $(LDADD_DRIVERS) $(LIBUSB_LIBS) -lm
22
- nutdrv_atcl_usb_SOURCES = nutdrv_atcl_usb.c usb-common.c