Browse Source

znc: enable features/support explicitly

Don't let znc autodetect library presence to avoid random missing
dependencies popping up.

Closes #2193.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
Jonas Gorski 9 years ago
parent
commit
b1a2b9d1ea
1 changed files with 12 additions and 2 deletions
  1. 12
    2
      net/znc/Makefile

+ 12
- 2
net/znc/Makefile View File

@@ -277,8 +277,18 @@ CONFIGURE_VARS += \
277 277
 	LIBS="-lstdc++ -lm -lssl -lcrypto $(LIBGCC_S) -lc"
278 278
 
279 279
 CONFIGURE_ARGS += \
280
-	--disable-c-ares \
281
-	--disable-perl
280
+	--disable-charset \
281
+	--disable-cyrus \
282
+	--disable-debug \
283
+	--enable-largefile \
284
+	--disable-perl \
285
+	--enable-poll \
286
+	--disable-python \
287
+	--enable-ssl \
288
+	--disable-swig \
289
+	--disable-tcl \
290
+	--enable-tdns \
291
+	--enable-zlib
282 292
 
283 293
 define Build/Configure
284 294
 	$(call Build/Configure/Default,)